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Chapter 1 Media Gateway - Connecting ISDN /

SIP clients to the SIP provider with bandwidth

management

1.1 Introduction

Media gateway serves as a translation instance between different telecommunications net-

works, e.g between the plain old phone network and the next generation networks (IP net-

works). With the bintec Media Gateway, a company equipped with an automatic PBX on a

wired telephone network can be connected to a SIP Trunking Service Provider on the Inter-

net in order to use IP telephony. The bintec Media Gateway supports the binding of several

SIP Provider Accounts.

The following chapter describes how to connect an SIP telephone and an ISDN PBX to the

media gateway. The media gateway is connected to an SIP provider and to an external

ISDN point-to-multipoint connection simultaneously.

The media gateway is connected to the Internet over an ADSL connection. Consequently,

this section also discusses the functions Application Level Gateway (NAT Proxy), band-

width management through the functions Quality of Service and Real Time Jitter Control

(Jitter reduction).

In this example scenario the following call assignment is set up:

Call Assignment

External number External medium Internal number Internal device

0911/2557435 ISDN 10 IP telephone

0911/2558296 ISDN 20 ISDN PBX

0911/30839681 SIP 20 ISDN PBX

bintec elmeg GmbH 1 Media Gateway - Connecting ISDN / SIP clients to the

SIP provider with bandwidth management
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Fig. 1: Example scenario

Requirements

The following are required for the configuration:

• Boot image from version 7.8.2

• A bintec Media Gateway

• The optional DSP module must be set up in the gateway

• The optional licence for the second ISDN interface is required

• The ADSL connection to the gateway must be set up in advance

Configuration in this scenario is carried out using the GUI (Graphical User Interface).

1.2 Configuration

1.2.1 Configuring the external ISDN interface

You can use the ISDN BRI interface of your device for both dialup and leased lines over

ISDN.

The external ISDN interface is connected directly with an NTBA (Network Termination

Basis Connection). On this connection the extensions 2557435 and 2558296 are switched.

Go to the following menu to configure the ISDN interface for your device:

(1) Go to Physical Interfaces ->ISDN Ports -> <bri2-0 (TE)> .

1 Media Gateway - Connecting ISDN / SIP clients to the

SIP provider with bandwidth management
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Fig. 2: Physical Interfaces -> ISDN Ports -> <bri2-0 (TE)> .

Relevant fields in the ISDN Configuration menu

Field Meaning

Port Name Shows the name of the ISDN port.

Autoconfiguration on

Bootup

Here, select whether the ISDN switch type should be automatic-

ally recognised.

Result of Autoconfigura-

tion

The status of the ISDN autoconfiguration is displayed here.

Automatic D-channel recognition runs until a setting is found.

This field cannot be edited.

Port Usage
If the ISDN protocol is not automatically recognised, you must

select the port here manually. For this, you must first disable

Automatic Configuration at Start.

Select .

ISDN Configuration

Type

Here, select the ISDN access configuration

.

MSN Configuration

If no entry is specified (in the ex works state no MSN number is entered), every incoming

ISDN call is accepted by the ISDN Login service. To avoid this, you should make the ne-

cessary entries here. As soon as an entry exists, the incoming calls not assigned to any

entry are forwarded to the CAPI service.

(1) Go to Physical Interfaces -> ISDN Ports -> MSN Configuration -> New.

bintec elmeg GmbH 1 Media Gateway - Connecting ISDN / SIP clients to the
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Fig. 3: Physical Interfaces -> ISDN Ports -> MSN Configuration -> New

Relevant fields in the MSN Configuration menu

Field Meaning

ISDN Port Select the ISDN port for which the MSN is to be configured.

Service Select the service to which a call is to be assigned on the num-

ber below.

MSN Enter the call number.

MSN Recognition Select the mode your device is to use for the number comparis-

on for MSN with the of the incoming

call. By default, the value is set on . Select the

value if your device is connected to a

point-to-point connection.

Service attribute Select the type of incoming call (service detection).

specifies that both data and voice calls (default value)

are executed.

1.2.2 Configuring the internal ISDN interface

The optional 1-BRI licence is required to be able to use the second ISDN interface. The

second ISDN port is operated as a point-to-multipoint connection in NT mode so that the

external ISDN line of the PBX (point-to-multipoint connection; TE mode) can be operated.

To be able to operate the 2. ISDN interface in NT mode, several link plugs (jumpers) in the

device must be modified:

For further information on setting the ISDN interfaces see Release Notes 7.5.1 (Chapter:

2.2 Variable switching for ISDN S0 interfaces).

(1) Go to Physical Interfaces ->ISDN Ports-><bri2-3 (NT)> .

1 Media Gateway - Connecting ISDN / SIP clients to the

SIP provider with bandwidth management
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Fig. 4: Physical Interfaces ->ISDN Ports-><bri2-3 (NT)> .

Relevant fields in the ISDN Configuration menu

Field Meaning

Port Name Shows the name of the ISDN port.

Port Usage Here, select .

ISDN Configuration

Type

Select the ISDN access configuration

.

MSN Configuration

As on the external ISDN port, a dummy subscriber number must also be saved for the in-

ternal ISDN port.

(1) Go to Physical Interfaces -> ISDN Ports -> MSN Configuration -> New.

Fig. 5: Physical Interfaces -> ISDN Ports -> MSN Configuration -> New

Relevant fields in the MSN Configuration menu

Field Meaning

ISDN Port Select the ISDN port for which the MSN is to be configured.

Service Select the service to which a call is to be assigned on the num-

ber below.

bintec elmeg GmbH 1 Media Gateway - Connecting ISDN / SIP clients to the
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Field Meaning

MSN Enter the call number.

MSN Recognition Select the mode your device is to use for the number comparis-

on for MSN with the of the incoming

call. By default, the value is set on .

Service attribute Select the type of incoming call (service detection).

specifies that both data and voice calls (default value)

are executed.

1.2.3 Enabling the Application Level Gateway for dynamic

monitoring of the NAT and firewall

To enable IP telephones to connect by SIP to a VoIP Provider your device has an Applica-

tion Level Gateway (ALG), i.e. an appropriate proxy that implements the necessary NAPT

and firewall releases.

Note

The Application Level Gateway must always be used if NAT is enabled on the inter-

face that makes the connection to the Internet.

In the VoIP-> Application Level Gateway menu, a list is shown of all configured Applica-

tion Level Gateway entries. These entries enable the ALG. Each entry defines a particular

TCP or UDP destination port that is to be supervised by the ALG. In the ex works state,

there are two entries configured for the SIP Ports TCP 5060 and UDP 5060 in accordance

with the IANA definition.

The router is connected to the internet via an ADSL line. The NAT firewall is active for this

connection. No portforwarding is required to open the NAT firewall for the VoIP data (SIP

and RTP), instead the Application Level Gateway must be enabled. The Low Latency

Transmission option highlights the VoIP data for the high priority queue relating to QoS.

Go to the following menu to configure an Application Level Gateway entry:

(1) Go to VoIP -> Application Level Gateway -> SIP-Proxys -><SIP UDP 5060> .

1 Media Gateway - Connecting ISDN / SIP clients to the

SIP provider with bandwidth management
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Fig. 6: VoIP -> Application Level Gateway -> SIP-Proxys -><SIP UDP 5060> .

Relevant fields in the SIP Proxies menu

Field Meaning

Description Displays the name of the Application Level Gateway entry.

Administrative Status Determines whether or not the proxy should be active.

Protocol Defines the protocol to be used.

Destination Port Here you enter the port to be supervised by the proxy.

Session Timeout Shows the time in seconds for which a session stays up if no

data packets are sent or received.

Low Latency Transmis-

sion Mechanism to minimise the transit time of VoIP data packets

between two subscribers. This guarantees good voice quality

with high line load.

Note that Low Latency Transmission does not have to be

switched on if the media gateway supervises the VoIP connec-

tion.

The voice quality is optimised by choosing .

1.2.4 Registering the router with VoIP provider sipgate.de

If your want your device is to connect to other SIP servers (e.g. servers of Internet SIP Ser-

vice providers), you can configure the necessary entries here.

Note

In no case should you use this menu to configure extensions, i.e. for SIP clients or

PSTN clients such as SIP telephones, terminal adapters or ISDN telephones Exten-

sions can be configured in the menu VoIP-> Media Gateway -> Call transformation -

> New.

bintec elmeg GmbH 1 Media Gateway - Connecting ISDN / SIP clients to the
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After installing the DSP module, you can save the login data for the extension.

(1) For this, go to VoIP -> Media Gateway -> SIP Accounts -> New.

Fig. 7: VoIP -> Media Gateway -> SIP Accounts -> New

Relevant fields in the SIP Accounts menu

Field Meaning

Description Here, assign a name to the account. Maximum number of char-

acters: 40.

Administrative Status Enable the administrative status of the account.

Trunk Mode Select the trunk mode to be used. If you select , the trunk

mode is not used.

Registrar Enter the IP address of the remote SIP terminal (client or serv-

er) here. Maximum number of characters: 40.

Protocol Select the protocol to be used for the connection to the server

or proxy.

1 Media Gateway - Connecting ISDN / SIP clients to the

SIP provider with bandwidth management
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Field Meaning

Port Number of the TCP or UDP port to be used for the connection

to the server or proxy.

User Name Here, enter the username for authentication if your VoIP pro-

vider has assigned one to you.

Authentication ID Enter a name that is to be used for authentication. If you do not

enter a name, the name in the User Name field is used.

Password The VoIP provider gives you a PIN or password for authentica-

tion. You must enter this value here. Maximum number of char-

acters: 40.

Registration Enables or disables the SIP REGISTER registration mechan-

ism.

Expire Time Shows the time in seconds after which the current registration

becomes invalid and a new registration request is therefore

sent.

In the Advanced settings menu, you can define which codecs are used for the chosen ac-

count.

Note

The codecs actually used are the intersect of the codecs defined here and those sig-

nalled by the provider. For outgoing calls, any remaining codecs are dropped from the

list that would require more than the available bandwidth.

Relevant fields in the menu Advanced Settings

Field Meaning

Codec Proposal Se-

quence Determine the order in which the codecs are offered for use by

the media gateway. If the first codec cannot be applied, an at-

tempt is made to use the second codec, and so on. Set Codec

Proposal Sequence to . The codec in the first posi-

tion will be used.

You can sort the codecs according to quality or bandwidth.

Sort Order Select the codecs to be proposed for the connection. The co-

decs chosen here are proposed in a certain order, depending

on the setting in the Codec Proposal Sequence field.

Echo cancellation Enable or disable echo cancellation. If is selected,

echo feedback is suppressed.

bintec elmeg GmbH 1 Media Gateway - Connecting ISDN / SIP clients to the
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Field Meaning

Comfort Noise Genera-

tion (CNG) Specify whether Comfort Noise Generation should be used. The

slight comfort noise generation prevents subscribers from think-

ing that the connection is lost during pauses.

Packet Size The transmission time of an RTP data packet in milliseconds.

Possible values: 10 ... 60.

If registration with the VoIP provider is successful, the status in the provider menu shows

. The status of the VoIP connection is changed by pressing the button or button in

the Action column.

(1) Go to VoIP -> Media Gateway -> SIP Accounts.

Fig. 8: VoIP -> Media Gateway -> SIP Accounts

1.2.5 Configuring the internal extension

Here you can configure the subscriber numbers for the terminals that are connected to the

media gateway.

In this example two internal extensions are used. Extension 10 for the IP telephone and ex-

tension 20 for the PBX connected to the internal ISDN port.

Configuring extension 10 - IP telephone

(1) Go to VoIP -> Media Gateway -> Extensions -> New.

1 Media Gateway - Connecting ISDN / SIP clients to the

SIP provider with bandwidth management
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Fig. 9: VoIP -> Media Gateway -> Subscriber -> New

Relevant fields in the Extensions menu

Field Meaning

Description Enter the name of the terminal.

Extension / User Name Enter the call number. A maximum of 40 characters can be

entered.

Interface Type Select the interface type to be used.

Registration Enables or disables the SIP REGISTER registration mechan-

ism.

Expire Time Enter the time in seconds after which the current registration be-

comes invalid and a new registration request is therefore sent.

Authentication ID
Here you can enter a name that is to be used for authentication.

The name given here must also be entered on the SIP tele-

phone.

Maximum number of characters: 20.

Password
Enter a password here. The password given here must also be

bintec elmeg GmbH 1 Media Gateway - Connecting ISDN / SIP clients to the
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Field Meaning

entered on the SIP telephone.

Maximum number of characters: 20.

Protocol Select the protocol to be used for data transmission.

Port Select the port to be used for data transmission.

In the Advanced Settings menu you can select the possible codecs for the account.

Relevant fields in the menu Advanced Settings

Field Meaning

Codec Proposal Se-

quence Determine the order in which the codecs are offered for use by

the media gateway. If the first codec cannot be applied, an at-

tempt is made to use the second codec, and so on. Set Codec

Proposal Sequence to . The codec in the first posi-

tion will be used.

You can sort the codecs according to quality or bandwidth.

Sort Order Select the codecs to be proposed for the connection. The co-

decs chosen here are proposed in a certain order, depending

on the setting in the Codec Proposal Sequence field.

Echo cancellation Enable or disable echo cancellation. If is selected,

echo feedback is suppressed.

Comfort Noise Genera-

tion (CNG) Specify whether Comfort Noise Generation should be used. The

slight comfort noise generation prevents subscribers from think-

ing that the connection is lost during pauses.

Packet Size The transmission time of an RTP data packet in milliseconds.

Possible values: 10 ... 60.

Configuring extension 20 - internal PBX

(1) Go to VoIP -> Media Gateway -> Extensions -> New.

1 Media Gateway - Connecting ISDN / SIP clients to the

SIP provider with bandwidth management
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Fig. 10: VoIP -> Media Gateway -> Subscriber -> New

Relevant fields in the Extensions menu

Field Meaning

Description Enter the name of the terminal.

Extension / User Name Enter the call number. A maximum of 40 characters can be

entered.

Interface Type
Terminal type, an internal PBX is used for the call.

The setting can only be selected if ISDN interfaces with

the ISDN Configuration Type =

is set.

Select ISDN interface Select an ISDN interface. The ISDN interfaces you can select

depends on the device used.

1.2.6 Call assignment - Call Routing - CLID Translation

You can configure the PBX functions for the media gateway in the menu VoIP -> Media

Gateway -> Options.

In addition to the call assignment, here you can configure the delay between entering the

subscriber number and starting to dial (Dialling ).

(1) Go to VoIP -> Media Gateway -> Options.
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Fig. 11: VoIP -> Media Gateway -> Options

Relevant fields in the Options menu

Field Meaning

Session Border Control-

ler Mode Determines the behaviour of the media gateway in combination

with a session border controller.

• : for all extensions that exactly agree with an existing ac-

count, the call routing is handled by the session border con-

troller, i.e. all SIP messages configured for the corresponding

account are forwarded to the session border controller. For all

other extensions, call routing is handled by the media gate-

way in accordance with the configured call routing entries.

Note that the call routing is handled by the media gateway if

the provider is not available (backup).

• : call routing is handles exclusively by the media gateway

in accordance with the configured call routing and the local

extensions. For calls that are to be routed via a particular pro-

vider (account), you must configure a corresponding call rout-

ing entry. Internal calls (from internal extension to internal ex-

tension) that are only to be routed internally do not require an

additional call routing entry.

• : A SIP trunk account is configured and selec-

ted for the session border controller under VoIP -> Media

Gateway -> SIP Accounts. In this case, the call routing for all

extensions is handled by the session border controller, all SIP

messages configured for the selected account are forwarded

to the session border controller. Note that the call routing is

handled by the media gateway if the provider is not available

(backup).

Media Stream Termina-

tion Determines how RTP sessions are controlled by the system.
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Field Meaning

• : RTP sessions are terminated on the media gate-

way, i.e. all RTP streams are controlled by the media gateway

and routed via the media gateway. The participating terminal

devices (e.g. SIP telephones) are not connected directly with

one another.

Note that, for VoIP to VoIP connections, there is no code

translation for different VoIP terminal codecs. This is why the

codecs from media gateway and VoIP terminals must match;

the RTP sessions are not terminated on the media gateway,

i.e. all RTP streams are routed from the media gateway

without termination. The RTP data packets can be routed in

complex networks and thus also via other gateways.

• (default value): RTP sessions are not terminated

on the media gateway, i.e. all RTP streams are routed by the

media gateway without termination. The RTP data packets

can be routed in complex networks and thus also via other

gateways.

Default Drop Extension Here you can nominate an extension to receive calls that cannot

be routed because there is no valid routing entry for them.

Dialling break
Maximum delay time before the system assumes the telephone

number entered is complete and starts the SIP dialling process

(sends the SIP INVITE message).

This timeout is reset each time that a button is pressed. If you

terminate the number entered with #, dialling is immediate.

Call Routing

In the Call Routing menu, you can define the conditions for the routing of calls.

In this example, an outgoing call made to a number starting with a 0 is routed with the

same subscriber number to the external ISDN connection. If the destination number starts

with a 9, the 9 (which is used as a trunk prefix) is replaced by 0049 and is sent over the

VoIP connection to the provider sipgate.

Since the internal ISDN connection has been configured as a point-to-multipoint connec-

tion, the type is used instead of a . Proceed as follows to configure the

VoIP connection to the provider sipgate.

(1) Go to VoIP -> Media Gateway -> Call Routing -> New.
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Fig. 12: VoIP -> Media Gateway -> Call Routing -> New

Relevant fields in the Call Routing menu

Field Meaning

Description Here, enter the name of the call routing entry.

Administrative Status The entry is used with .

Type Select for calls that are to be routed as outgoing, ex-

ternal calls.

Calling Line Here you can restrict the routing entry to the line on which the

call comes in.

Calling Address Here you can restrict the routing entry to a particular caller. To

do this, you must specify the subscriber number exactly (no

wildcards).

Called Address Here, you can enter an address (call number) that is compared

with the dialled address. You can use wildcards here. For ex-

ample means that at the end of a character string an arbit-

rary number of any characters can follow.

You can now create a list with rules that are assigned to the currently selected routing

entry, and that serve to manipulate the signalled destination number. You can also delete

routing entries.

Use Add to create entries.
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Relevant fields in the Routing Rule menu

Field Meaning

Priority Determines the order of the filter rules, starting with in in-

creasing numerical order.

Administrative Status The entry is used with .

Outbound Line Defines the PSTN line (PRI, BRI, FXO) or the SIP account used

for an outgoing call.

Called Address Transla-

tion

The rule shown <9:0049> indicates how the destination number

is manipulated. Before it is used for a call, the used as the

trunk prefix is replaced by the number .

CLID Translation

In the CLID Translation menu, you can create a list for the translation of subscriber num-

bers, i.e. this list associates internal and external numbers.

The CLID Translation is crucial in this example for incoming calls. For incoming ISDN calls

to extension 2557435, this number is replaced by extension 10. The connection is routed to

local extension 10 (SIP telephone). Calls on the SIP account and on the ISDN number

2558296 will be routed to the PBX connection.

(1) Go to VoIP -> Media Gateway -> CLID Translation -> New.

Fig. 13: VoIP -> Media Gateway -> CLID Translation -> New

Relevant fields in the CLID Translation menu

Field Meaning

Description Here, enter the name of the CLID translation entry.

Call number Select the line or SIP account via which the calls are to be

routed.

Called Line
Here you enter the direction to which the entry is to apply.
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Field Meaning

Select for incoming and outgoing calls (bidirectional).

Called Address Here you have the option of entering the destination address of

the call.

Calling Address Transla-

tion

Enter the transformation rule applied to the call numbers.

Proceed as with configuration of numbers 1839681 -> 20 and 2558296 -> 20. The final

configuration looks like this:

(1) Go to VoIP -> Media Gateway -> CLID Translation .

Fig. 14: VoIP -> Media Gateway -> CLID Translation

Real Time Jitter Control

For telephone calls over the Internet, VoIP packets normally have the highest priority. Nev-

ertheless, if the upstream bandwidth is low, noticeable delays in voice transmission can oc-

cur when other packets are routed at the same time. The Real Time Jitter Control func-

tion in the VoIP implementation solves this problem. So as not to block the "line" for VoIP

packets for too long, the size of other data packets is reduced if need be during a tele-

phone call.

(1) Go to WAN->Real Time Jitter Control->Controlled Interfaces->New.
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Fig. 15: WAN->Real Time Jitter Control->Controlled Interfaces-> New

Relevant fields in the Controlled Interfaces menu

Field Meaning

Interface Here you select the Interface on which the voice transmission is

to be optimised.

Control Mode
Select the mode for the optimisation.

Select : By means of the

data routed through the media gateway, the system recognises

VoIP data traffic and optimises the voice transmission. This set-

ting should always be used together with the media gateway.

Maximum Upload Speed

(kbit/s)

If you're using an external DSL modem, enter the bandwidth in

the upload directions in kbit/s for the selected interface.

Policies

If the Internet connection of the router is used for normal internet traffic or VPN connec-

tions, for example, in addition to VoIP data traffic, QoS must be enabled.

When setting up the Application Level Gateway option, enabling Low Latency Trans-

mission automatically performed QoS classification. All VoIP data (SIP and RTP) are high-

lighted for the . To improve QoS monitoring, a

without bandwidth restriction should be stored in the QoS configuration alongside

the .

(1) Go to Firewall -> Policies -> Filter Rules ->New.
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Fig. 16: Firewall->Policies->Filter Rules->New

Relevant fields in the Filter Rules menu

Field Meaning

Source Location Select one of the preconfigured aliases for the source of the

packet. The value means that neither the source interface

nor the source address is checked.

Destination Select one of the preconfigured aliases for the destination of the

packet. The value means that neither the destination inter-

face nor the destination address is checked.

Service Select one of the preconfigured services to which the packet to

be filtered must be assigned.

Action Select the action to be applied to a filtered packet. If you select

the option, packets are passed according to the in-

struction.

Apply QoS Select whether you want to enable QoS for this policy with the

priority selected in Data Traffic Priority

Traffic Priority Select the priority with which the data specified by the policy is

handled on the send side.

Monitoring

The Monitoring menu contains submenus that enable you to locate problems in your net-

work and monitor activities, e.g. for bandwidth management.

(1) Go to Monitoring -> Interfaces -> Statistics.
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Fig. 17: Monitoring -> Interfaces -> Statistics

You change the state of the interface by pressing the button or button in the Action

column. Press the button to display the statistical data for the individual interfaces in de-

tail.

1.3 Overview of configuration steps

Configuring the external ISDN interface

Field Menu Value

Autoconfiguration on Bootup Physical Interfaces -> ISDN

Ports -> ISDN Configura-

tion -> <bri2-0 (TE)

Result of Autoconfiguration Physical Interfaces -> ISDN

Ports -> ISDN Configura-

tion -> <bri2-0 (TE)

MSN Configuration

Field Menu Value

ISDN Port Physical Interfaces -> ISDN

Ports -> MSN Configura-

tion -> New

Service Physical Interfaces -> ISDN

Ports -> MSN Configura-

tion -> New

e.g.

MSN Physical Interfaces -> ISDN e.g.

bintec elmeg GmbH 1 Media Gateway - Connecting ISDN / SIP clients to the

SIP provider with bandwidth management

Workshops (Excerpt) 21



Field Menu Value

Ports -> MSN Configura-

tion -> New

MSN Recognition Physical Interfaces -> ISDN

Ports -> MSN Configura-

tion -> New

Service attribute Physical Interfaces -> ISDN

Ports -> MSN Configura-

tion -> New

Configuring the internal ISDN interface

Field Menu Value

Port Usage Physical Interfaces -> ISDN

Ports -> ISDN Configura-

tion -> <bri2-3 (NT)

ISDN Configuration Type Physical Interfaces -> ISDN

Ports -> ISDN Configura-

tion -> <bri2-3 (NT)

MSN Configuration

Field Menu Value

ISDN Port Physical Interfaces -> ISDN

Ports -> MSN Configura-

tion -> New

Service Physical Interfaces -> ISDN

Ports -> MSN Configura-

tion -> New

e.g.

MSN Physical Interfaces -> ISDN

Ports -> MSN Configura-

tion -> New

e.g.

MSN Recognition Physical Interfaces -> ISDN

Ports -> MSN Configura-

tion -> New

Service attribute Physical Interfaces -> ISDN

Ports -> MSN Configura-

tion -> New

Application Level Gateway

Field Menu Value

Description VoIP -> Application Level
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Field Menu Value

Gateway -> SIP Proxies

Administrative Status VoIP -> Application Level

Gateway -> SIP Proxies

Protocol VoIP -> Application Level

Gateway -> SIP Proxies

Destination Port VoIP -> Application Level

Gateway -> SIP Proxies

Session Timeout VoIP -> Application Level

Gateway -> SIP Proxies

Low Latency Transmission VoIP -> Application Level

Gateway -> SIP Proxies

Configuration of SIP accounts

Field Menu Value

Description VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

Administrative Status VoIP -> Media Gateway ->

SIP Accounts -> New

Trunk Mode VoIP -> Media Gateway ->

SIP Accounts -> New

Registrar VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

Protocol VoIP -> Media Gateway ->

SIP Accounts -> New

Port VoIP -> Media Gateway ->

SIP Accounts -> New

User Name VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

Password VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

Registration VoIP -> Media Gateway ->

SIP Accounts -> New

Expire Time VoIP -> Media Gateway ->

SIP Accounts -> New

Codec Proposal Sequence VoIP -> Media Gateway ->

SIP Accounts -> New-> Ad-
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Field Menu Value

vanced Settings

Sort Order VoIP -> Media Gateway ->

SIP Accounts -> New-> Ad-

vanced Settings

, ,

,

Echo cancellation VoIP -> Media Gateway ->

SIP Accounts -> New-> Ad-

vanced Settings

Comfort Noise Generation

(CNG)

VoIP -> Media Gateway ->

SIP Accounts -> New-> Ad-

vanced Settings

Packet Size VoIP -> Media Gateway ->

SIP Accounts -> New-> Ad-

vanced Settings

e.g.

Configuring the internal extension

Field Menu Value

Description VoIP -> Media Gateway ->

Subscriber -> New

e.g.

Extension / User Name VoIP -> Media Gateway ->

Subscriber -> New

e.g.

Interface Type VoIP -> Media Gateway ->

Subscriber -> New

e.g.

Registration VoIP -> Media Gateway ->

Subscriber -> New

Expire Time VoIP -> Media Gateway ->

Subscriber -> New

Sec

Authentication ID VoIP -> Media Gateway ->

Subscriber -> New

e.g.

Password VoIP -> Media Gateway ->

Subscriber -> New

e.g.

Protocol VoIP -> Media Gateway ->

Subscriber -> New

e.g.

Port VoIP -> Media Gateway ->

Subscriber -> New

Codec Proposal Sequence VoIP -> Media Gateway ->

Extensions -> New-> Ad-

vanced Settings

Sort Order VoIP -> Media Gateway -> , ,
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Field Menu Value

Extensions -> New-> Ad-

vanced Settings

,

Echo cancellation VoIP -> Media Gateway ->

Extensions -> New-> Ad-

vanced Settings

Comfort Noise Generation

(CNG)

VoIP -> Media Gateway ->

Extensions -> New-> Ad-

vanced Settings

Packet Size VoIP -> Media Gateway ->

Extensions -> New-> Ad-

vanced Settings

e.g.

Configuring the internal PBX

Field Menu Value

Description VoIP -> Media Gateway ->

Subscriber -> New

e.g.

Extension / User Name VoIP -> Media Gateway ->

Subscriber -> New

e.g.

Interface Type VoIP -> Media Gateway ->

Subscriber -> New

e.g.

Select ISDN interface VoIP -> Media Gateway ->

Subscriber -> New

e.g.

Configuration of PBX functions

Field Menu Value

Session Border Controller

Mode

VoIP -> Media Gateway ->

Options

Media Stream Termination VoIP -> Media Gateway ->

Options

Disabled

Dialling break VoIP -> Media Gateway ->

Options

seconds

Call Routing

Field Menu Value

Description VoIP -> Media Gateway ->

Call Routing -> New

e.g.

Administrative Status VoIP -> Media Gateway ->

Call Routing -> New
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Field Menu Value

Type VoIP -> Media Gateway ->

Call Routing -> New

Calling Line VoIP -> Media Gateway ->

Call Routing -> New

Called Address VoIP -> Media Gateway ->

Call Routing -> New

e.g.

Priority VoIP -> Media Gateway ->

Call Routing -> New-> Add

Administrative Status VoIP -> Media Gateway ->

Call Routing -> New-> Add

Outbound Line VoIP -> Media Gateway ->

Call Routing -> New-> Add

e.g.

Called Address Translation VoIP -> Media Gateway ->

Call Routing -> New-> Add

e.g.

CLID Translation

Field Menu Value

Description VoIP -> Media Gateway ->

CLID Translation -> New

e.g. .

Call number VoIP -> Media Gateway ->

CLID Translation -> New

e.g.

Called Line VoIP -> Media Gateway ->

CLID Translation -> New

Called Address VoIP -> Media Gateway ->

CLID Translation -> New

e.g.

Calling Address Translation VoIP -> Media Gateway ->

CLID Translation -> New

e.g.

Description VoIP -> Media Gateway ->

CLID Translation -> New

e.g. .

Call number VoIP -> Media Gateway ->

CLID Translation -> New

e.g.

Called Line VoIP -> Media Gateway ->

CLID Translation -> New

Called Address VoIP -> Media Gateway ->

CLID Translation -> New

e.g.

Calling Address Translation VoIP -> Media Gateway ->

CLID Translation -> New

e.g. .
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Field Menu Value

Description VoIP -> Media Gateway ->

CLID Translation -> New

e.g. .

Call number VoIP -> Media Gateway ->

CLID Translation -> New

e.g.

Called Line VoIP -> Media Gateway ->

CLID Translation -> New

Called Address VoIP -> Media Gateway ->

CLID Translation -> New

e.g.

Calling Address Translation VoIP -> Media Gateway ->

CLID Translation -> New

e.g. .

Controlled Interfaces

Field Menu Value

Interface WAN->Real Time Jitter

Control->Controlled Inter-

faces->New

e.g.

Control Mode WAN->Real Time Jitter

Control->Controlled Inter-

faces->New

Maximum Upload Speed WAN->Real Time Jitter

Control->Controlled Inter-

faces->New

e.g. .

Filter Rules

Field Menu Value

Source Location Firewall->Policies->Filter

Rules->New

e.g.

Destination Firewall->Policies->Filter

Rules->New

e.g.

Service Firewall->Policies->Filter

Rules->New

e.g.

Action Firewall->Policies->Filter

Rules->New

Apply QoS Firewall->Policies->Filter

Rules->New

Traffic Priority Firewall->Policies->Filter

Rules->New
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Chapter 2 Media Gateway - Connection of an

Asterisk IP PBX to a point-to-point ISDN access

2.1 Introduction

The following chapter describes how to configure the bintec R4100 as a media gateway to

connect an Asterisk IP PBX to a point-to-point ISDN access.

A few extracts are shown from the Asterisk IP PBX configuration to ensure that registration

is successful, and that the subscriber number is transmitted correctly. At the exchange, an

ISDN party line is used (consisting of two point-to-point ISDN accesses with four B-

channels) with the subscriber number 0911/7660069(0-9).

Fig. 18: Example scenario

Requirements

The following are required for the configuration:

• Boot image from version 7.8.4

• A bintec Media Gateway

Configuration in this scenario is carried out using the GUI (Graphical User Interface).
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2.2 Configuration

2.2.1 Configuring the bintec R4100 media gateway

ISDN interface configuration

The ISDN interfaces ISDN-0 and ISDN-1 are used to connect the media gateway to the

point-to-point ISDN access. The ISDN Configuration Type must be set to

based on the point-to-point ISDN access for the

two interfaces BRI2-0 and BRI2-1.

Go to the following menu to configure the ISDN interface for your device:

(1) Go to Physical interfaces -> ISDN-Ports -> <bri2-0 (TE) .

Fig. 19: Physical Interfaces ->ISDN Ports-><bri2-0 (TE) .

Relevant fields in the ISDN Configuration menu

Field Meaning

Port Name Shows the name of the ISDN port.

Autoconfiguration on

Bootup

Here, select whether the ISDN switch type should be automatic-

ally recognised.

Result of Autoconfigura-

tion

The status of the ISDN autoconfiguration is displayed here.

Automatic D-channel recognition runs until a setting is found.

This field cannot be edited.

Port Usage
If the ISDN protocol is not automatically recognised, you must

select the port here manually. For this, you must first disable

Automatic Configuration at Start.
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Field Meaning

Select .

ISDN Configuration

Type

Here, select ISDN access configuration .

ISDN Trunks

The ISDN Trunks menu appears only if your device has at least one ISDN point-to-point

connection (BRI or PRI) and this connection is configured in NT mode.

In this example, an ISDN party line (consisting of two point-to-point ISDN accesses) is used

at the exchange. Both ISDN ports must be joined together so that both ISDN connections

can be used as a bundle. For this, go to the following menu:

(1) Go to VoIP -> Media Gateway -> ISDN Trunks-> New.

Fig. 20: VoIP ->Media Gateway-> ISDN Trunks -> New

Relevant fields in the ISDN Trunks menu

Field Meaning

Description
Here you give the party line a name.

Maximum number of characters: 20.

ISDN Mode
Displays the mode in which the party line is to be operated.

: Point-to-point TE connection (to connect to the

point-to-point ISDN access).

Enable the ISDN connections to be used for the party line.

Connecting the Asterisk to the bintec R4100
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An account must be created in which the media gateway is run as a SIP Server to register

the Asterisk IP PBX on bintec R4100.

In the Trunk Settings submenu you can define the settings for direct dial-in. An incoming

call can be routed to just one terminal device (direct dial-in). For an outgoing call, the caller

can be indicated to the called party.

Go to the following menu to configure the required accounts:

(1) Go to VoIP -> Media Gateway -> SIP Accounts-> New.

Fig. 21: VoIP -> Media Gateway -> SIP Accounts -> New

Relevant fields in the SIP Accounts menu

Field Meaning

Description Here, assign a name to the account. Maximum number of char-

acters: 40.

Administrative Status Enable or disable the administrative status of the account.
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Field Meaning

Trunk Mode
Select the trunk mode to be used. If you select , the me-

dia gateway is run as a SIP Server.

Realm Here you can enter a further domain name of the SIP Proxy

server. Enter a name only if this is explicitly specified by the pro-

vider. The field can also be used to identify the authorised user.

Protocol Select the protocol to be used for the connection to the server

or proxy.

Port Number of the TCP or UDP port to be used for the connection

to the server or proxy.

User Name Here, enter the username for authentication if your VoIP pro-

vider has assigned one to you.

Authentication ID Enter a name that is to be used for authentication. If you do not

enter a name, the name in the User Name field is used.

Password The VoIP provider gives you a PIN or password for authentica-

tion. You must enter this value here. Maximum number of char-

acters: 40.

Registration Enables or disables the SIP REGISTER registration mechan-

ism.

Expire Time Shows the time in seconds after which the current registration

becomes invalid and a new registration request is therefore

sent.

SIP Header Field(s) for

Caller Address This option defines where and how the DDI sender (caller) ad-

dress is sent for outgoing calls.

Select . The so-called "p-preferred-identity" field

is added to the SIP header and contains the sender address.

Call number Here you can set a number that is added as a prefix for outgo-

ing calls and is removed from the sender address for incoming

calls.

In the Advanced Settings menu, perform the settings for the SIP protocol and other spe-

cific settings.

In the Codec Settings submenu you can define which codecs are used for the chosen ac-

count.

The codec settings for the RTP streams can be applied without changes.

Some fields are optional and only have to be set if required for the corresponding account.
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Relevant fields in the menu Advanced Settings

Field Meaning

Codec Proposal Se-

quence Determine the order in which the codecs are offered for use by

the media gateway. If the first codec cannot be applied, an at-

tempt is made to use the second codec, and so on. Set Codec

Proposal Sequence to . The codec in the first posi-

tion will be used.

You can sort the codecs according to quality or bandwidth.

Sort Order Select the codecs to be proposed for the connection. The co-

decs chosen here are proposed in a certain order, depending

on the setting in the Codec Proposal Sequence field.

Echo cancellation Enable or disable echo cancellation. If is selected,

echo feedback is suppressed.

Comfort Noise Genera-

tion (CNG) Specify whether Comfort Noise Generation should be used. The

slight comfort noise generation prevents subscribers from think-

ing that the connection is lost during pauses.

Packet Size The transmission time of an RTP data packet in milliseconds.

Possible values: 10 ... 60.

Media Gateway Configuration

You can configure the PBX functions for the media gateway in the menu VoIP -> Media

Gateway -> Options.

Incoming and outgoing calls are managed and terminated by the bintec R4100 using the

Session Border Controller and Media Stream Termination settings shown.

(1) Go to VoIP -> Media Gateway -> Options.
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Fig. 22: VoIP -> Media Gateway -> Options

Relevant fields in the Options menu

Field Meaning

Session Border Control-

ler Mode Determines the behaviour of the media gateway in combination

with a session border controller.

• : for all extensions that exactly agree with an existing ac-

count, the call routing is handled by the session border con-

troller, i.e. all SIP messages configured for the corresponding

account are forwarded to the session border controller. For all

other extensions, call routing is handled by the media gate-

way in accordance with the configured call routing entries.

Note that the call routing is handled by the media gateway if

the provider is not available (backup).

• : call routing is handles exclusively by the media gateway

in accordance with the configured call routing and the local

extensions. For calls that are to be routed via a particular pro-

vider (account), you must configure a corresponding call rout-

ing entry. Internal calls (from internal extension to internal ex-

tension) that are only to be routed internally do not require an

additional call routing entry.

Media Stream Termina-

tion Determines how RTP sessions are controlled by the system.

• : RTP sessions are terminated on the media gate-

way, i.e. all RTP streams are controlled by the media gateway

and routed via the media gateway. The participating terminal

devices (e.g. SIP telephones) are not connected directly with

one another.

Note that, for VoIP to VoIP connections, there is no code

translation for different VoIP terminal codecs. The codecs of
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Field Meaning

media gateway and VoIP terminals must therefore agree.

RTP sessions are not terminated on the media gateway, i.e.

all RTP streams are routed by the media gateway without ter-

mination. The RTP data packets can be routed in complex

networks and thus also via other gateways.

• (default value): RTP sessions are not terminated

on the media gateway, i.e. all RTP streams are routed by the

media gateway without termination. The RTP data packets

can be routed in complex networks and thus also via other

gateways.

Default Drop Extension Here you can nominate an extension to receive calls that cannot

be routed because there is no valid routing entry for them.

Dialling break
Maximum delay time before the system assumes the telephone

number entered is complete and starts the SIP dialling process

(sends the SIP INVITE message).

This timeout is reset each time that a button is pressed. If you

terminate the number entered with #, dialling is immediate.

Call routing / Extension translation

In the Call Routing menu, you can define the conditions for the routing of calls.

In this example, 10 terminals are connected to the Asterisk IP PBX. The numbers 100 to

109 are used for the extension numbers. Based on the following call routing all calls with a

destination number starting with 10 are routed to the Asterisk IP PBX. This setting is neces-

sary to allow incoming calls (from ISDN to Asterisk).

(1) Go to VoIP -> Media Gateway -> Call Routing -> New.
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Fig. 23: VoIP -> Media Gateway -> Call Routing-> New

Relevant fields in the Call Routing menu

Field Meaning

Description Here, enter the name of the call routing entry.

Administrative Status The entry is used with .

Type Select for calls that are routed to a PBX behind the me-

dia gateway.

Calling Line Here you can restrict the routing entry to the line on which the

call comes in.

Calling Address Here you can restrict the routing entry to a particular caller. To

do this, you must specify the subscriber number exactly (no

wildcards).

Called Address Here, you can enter an address (call number) that is compared

with the dialled address. You can use wildcards here. For ex-

ample means that at the end of a character string an arbit-

rary number of any characters can follow.

Trunk Line Defines the line (PRI, BRI, FXO) or the SIP account used for an

incoming connection.

An additional entry is required for outgoing connections (from Asterisk to ISDN). If wild-

cards * are used in the Called Address option, all other calls are routed via the two point-

to-point ISDN accesses. The following setting ensures that all outgoing calls are routed via

the ISDN party line.

(1) Go to VoIP -> Media Gateway -> Call Routing -> New.
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Fig. 24: VoIP -> Media Gateway -> Call Routing-> New

Relevant fields in the Call Routing menu

Field Meaning

Description Here you give the entry a name.

Administrative Status The entry is used with .

Type Select for calls that are to be routed as outgoing ex-

ternal calls. This can be done using standard SIP accounts or

SIP trunking accounts in DDI client mode.

Calling Line Here you can restrict the routing entry to the line on which the

call comes in.

Called Address
Here you can enter an address numerically (e.g. a subscriber

number) or alphanumerically that is to be compared with a di-

alled address. You can use wildcards.

* means that at the end of a character string any number of

characters may follow,

If the configured address agrees with the signalled address, the

routing entry is used.

You can now create a list with connections over which outgoing calls can be sent. If the line

(SIP provider or ISDN line) cannot be used with Order 1, the line with the next highest or-

der will be used to establish the connection.
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Use Add to create entries.

Relevant fields in the Routing Rule menu

Field Meaning

Priority Determines the order of the filter rules, starting with in in-

creasing numerical order.

Admin Status The entry is used with .

Outbound Line Defines the PSTN line (PRI, BRI, FXO) or the SIP account used

for an outgoing call.

Call Translation

In the Call Translation menu, you can create a list for the translation of subscriber num-

bers, i.e. this list associates internal and external numbers.

Since the local extension numbers (numbers 100 to 109) must differ from the external num-

bers (0911/7660069(0-9)), the subscriber numbers have to be manipulated. In the Call

Translation menu, with outgoing connections the last digit of the outgoing subscriber num-

ber is kept while the previous digit of the subscriber number changes, e.g.

Local number = 100 ; External number = 091176600690 or

Local number = 101 ; External number = 091176600691 and so on

(1) Go to VoIP -> Media Gateway -> Call Translation -> New.

Fig. 25: VoIP -> Media Gateway -> Call Translation -> New

Relevant fields in the Call Translation menu

Field Meaning

Description Give the number translation a name.

Direction
Here you enter the direction to which the entry is to apply.
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Field Meaning

Select for outgoing calls.

Associated Line Determines the line or SIP account via which the calls are to be

routed.

Local Address
Here you enter the internal number (e.g. extension or PBX num-

ber).

For outgoing calls, the signalled Calling Party Number

(corresponds in the menu to the Local Address field) is trans-

lated to the External Address.

Numerical and alphanumerical characters are permissible.

? is a placeholder for an arbitrary digit.

Note Local Address and External Address must contain the

same number of wildcards.

External Address Enter the external number here. For outgoing calls, the sig-

nalled called party number (corresponding in the menu to the

Local Address field) is translated to the External Address.

In our example the destination number is transmitted without a dialling code for incoming

connections (from ISDN to Asterisk). Consequently, a further Call Translation rule is re-

quired. For example, an incoming call to the subscriber number 76600695 is changed to

destination number 105. Call Routing is then initiated and the call is routed to the Asterisk

IP PBX via the SIP trunk.

(1) Go to VoIP -> Media Gateway -> Call Translation -> New.

Fig. 26: VoIP -> Media Gateway -> Call Translation -> New

Relevant fields in the Call Translation menu
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Field Meaning

Description Give the number translation a name.

Direction
Here you enter the direction to which the entry is to apply.

Select for incoming calls.

Associated Line Determines the line or SIP account via which the calls are to be

routed.

Local Address
Here you enter the internal number (e.g. extension or PBX num-

ber).

For outgoing calls, the signalled Calling Party Number

(corresponds in the menu to the Local Address field) is trans-

lated to the External Address.

Numerical and alphanumerical characters are permissible.

? is a placeholder for an arbitrary digit.

Note Local Address and External Address must contain the

same number of wildcards.

External Address Enter the external number here. For incoming calls, the sig-

nalled Called Party Number (corresponds in the menu to the

External Address field) is translated to the Local Address.

2.2.2 Configuring Asterisk IP PBX

The two configuration files and are adjusted to the scen-

ario described above. The Asterisk configuration file is used to store general

settings along with the registration of the Asterisk IP PBX on bintec R4100 and the regis-

tration of the IP telephone on Asterisk IP PBX. Call routing for the IP PBX is defined in the

Asterisk configuration file . Both Asterisk configuration files are repres-

ented below.
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2.3 Overview of configuration steps

Configuring the external ISDN interface

Field Menu Value

Port Usage Physical Interfaces -> ISDN

Ports -> <bri2-0 (TE)>

ISDN Configuration Type Physical Interfaces -> ISDN

Ports -> <bri2-0 (TE)>

Port Usage Physical Interfaces -> ISDN

Ports -> <bri2-1 (TE)>

ISDN Configuration Type Physical Interfaces -> ISDN

Ports -> <bri2-1 (TE)>

Compile ISDN Trunks
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Field Menu Value

Description VoIP ->Media Gateway->

ISDN Trunks-> New

isdn_TE

ISDN Mode VoIP ->Media Gateway->

ISDN Trunks-> New

Enable and

Configuration of SIP accounts

Field Menu Value

Description VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

Administrative Status VoIP -> Media Gateway ->

SIP Accounts -> New

Trunk Mode VoIP -> Media Gateway ->

SIP Accounts -> New

Server

Protocol VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

Port VoIP -> Media Gateway ->

SIP Accounts -> New

User Name VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

Password VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

Registration VoIP -> Media Gateway ->

SIP Accounts -> New

Expire Time VoIP -> Media Gateway ->

SIP Accounts -> New

Sec

SIP Header Field(s) for

Caller Address

VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

Codec Proposal Sequence VoIP -> Media Gateway ->

SIP Accounts ->New Ad-

vanced Settings

e.g.

Echo cancellation VoIP -> Media Gateway ->

SIP Accounts ->New Ad-

vanced Settings

Comfort Noise Generation VoIP -> Media Gateway ->

SIP Accounts ->New Ad-

vanced Settings
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Field Menu Value

Packet Size VoIP -> Media Gateway ->

SIP Accounts ->New Ad-

vanced Settings

e.g. ms

Call assignment for incoming calls

Field Menu Value

Session Border Controller

Mode

VoIP -> Media Gateway ->

Options

Media Stream Termination VoIP -> Media Gateway ->

Options

Dialling break VoIP -> Media Gateway ->

Options

e.g. seconds

Call Routing

Field Menu Value

Description VoIP -> Media Gateway ->

Call Routing -> New

e.g.

Administrative Status VoIP -> Media Gateway ->

Call Routing -> New

Type VoIP -> Media Gateway ->

Call Routing -> New

Calling Line VoIP -> Media Gateway ->

Call Routing -> New

e.g.

Called Address VoIP -> Media Gateway ->

Call Routing -> New

e.g.

Trunk Line VoIP -> Media Gateway ->

Call Routing -> New

e.g.

Call routing for outgoing calls

Field Menu Value

Description VoIP -> Media Gateway ->

Call Routing -> New

e.g.

Administrative Status VoIP -> Media Gateway ->

Call Routing -> New

Type VoIP -> Media Gateway ->

Call Routing -> New

Calling Line VoIP -> Media Gateway ->

Call Routing -> New

e.g.
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Field Menu Value

Called Address VoIP -> Media Gateway ->

Call Routing -> New

e.g.

Administrative Status VoIP -> Media Gateway ->

Call Routing -> New-> Add

Outbound Line VoIP -> Media Gateway ->

Call Routing -> New-> Add

e.g.

Call Translation

Field Menu Value

Description VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Direction VoIP -> Media Gateway ->

Call Translation -> New

Associated Line VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Local Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

External Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Description VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Direction VoIP -> Media Gateway ->

Call Translation -> New

Associated Line VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Local Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

External Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.
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Chapter 3 Media Gateway - Configuring the

connection of an ISDN PABX to a SIP trunking

account with provider QSC

3.1 Introduction

The following chapters describe how to configure a bintec R4100 as a media gateway to

connect an ISDN PBX to a QSC SIP trunking account. The ISDN PBX has been set up for

operation on a point-to-point ISDN access.

In our example, the main number for the point-to-point ISDN access 9673 and the direct di-

alling range numbers of the extensions is a two-digit number. The PABX is connected to

the media gateway over an ISDN port. The second ISDN port of the media gateway is con-

nected with an exchange-based point-to-point ISDN access and serves as an ISDN backup

line.

Fig. 27: Example scenario

Requirements

The following are required for the configuration:

• A bintec media gateway with system software 7.6.6.

• A DSP module (4-way) must be installed

• An Internet connection with sufficient bandwidth (recommended uplink bandwidth >= 256

kbp/s)
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Configuration in this scenario is carried out using the GUI (Graphical User Interface).

3.2 Configuration

3.2.1 Configuring the ISDN interfaces

ISDN port ISDN-0 on bintec R4100 is connected to the NTBA (Network Termination Basis

Connection) of the ISDN backup line. The ISDN ports of the media gateway are already en-

abled in ISDN TE mode in the ex works state and the ISDN switch type is recognised auto-

matically when starting the media gateway. As a result, no changes have to be made for

this ISDN port.

(1) Go to Physical Interfaces -> ISDN Ports -> ISDN Configuration -> <bri2-0 (TE)

Fig. 28: Physical Interfaces -> ISDN Ports -> ISDN Configuration -> <bri2-0 (TE)

ISDN mode must be changed to before the ISDN PBX can connect to the media

gateway at port . To do this, the housing on the media gateway must be opened.

The link plugs for the ISDN-0 and ISDN-1 interfaces can be found on all devices on the

main PCB behind the ISDN terminal block.

Insert the link plugs for interfaces ISDN-0 and ISDN-1 as follows:

Internal/external switching J0M External (factory default setting)

Internal/external switching J1M internal

Power supply J0P Off (factory default setting)

Power supply J1P On

Terminator J0T Off (factory default setting)

Terminator J1T On
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For further information on setting the ISDN interfaces see Release Notes 7.5.1 (Chapter:

2.2 Variable switching for ISDN S0 interfaces).

Once the interface has been set by changing the link plugs to ISDN NT mode, you

can configure the port for connecting the PBX. As the PBX has been configured for opera-

tion on a point-to-point ISDN access, you must set the ISDN Configuration Type to

on the media gateway.

(1) Go to Physical Interfaces -> ISDN Ports -> ISDN Configuration -> <bri2-1 (NT)

Fig. 29: Physical Interfaces -> ISDN Ports -> ISDN Configuration -> <bri2-1 (NT)

Relevant fields in the ISDN Configuration menu

Field Meaning

Port Name Shows the name of the ISDN port.

Port Usage Select the protocol that you wish to use for the ISDN port, in this

case .

ISDN Configuration

Type

Here, select ISDN access configuration .

3.2.2 Configuring the QSC SIP trunking accounts

The login data for registering the SIP trunking accounts with provider QSC are entered in

the SIP Accounts menu.

In the Trunk Settings submenu, you can define the settings for direct dial-in. An incoming

call can be routed to just one terminal device (direct dial-in). For an outgoing call, the caller

can be indicated to the called party.

The following settings ensures that your own subscriber number is transmitted correctly

with outgoing calls. With a QSC SIP trunking account, your own subscriber number (with

attached direct dialling range number) is indicated in the SIP header field for caller address

.
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To create the account, add a new entry and configure the account as indicated below.

(1) Go to VoIP -> Media Gateway -> SIP Accounts-> New.

Fig. 30: VoIP -> Media Gateway -> SIP Accounts -> New

Relevant fields in the SIP Accounts menu

Field Meaning

Description Here, assign a name to the account. Maximum number of char-

acters: 40.

Administrative Status Enable the administrative status of the account.

Trunk Mode Select the trunk mode to be used. If you select , the me-

dia gateway is run as a SIP client.

Registrar Here, enter the IP address of the SIP registrar or of the SIP

proxy server. Maximum number of characters: 40.
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Field Meaning

Protocol Select the protocol to be used for data transport.

Port Number of the TCP or UDP port to be used for the connection

to the server or proxy.

User Name Here, enter the username for authentication if your VoIP pro-

vider has assigned one to you.

Authentication ID Enter a name that is to be used for authentication. If you do not

enter a name, the name in the User Name field is used.

Password The VoIP provider gives you a PIN or password for authentica-

tion. You must enter this value here. Maximum number of char-

acters: 40.

Registration Enables or disables the SIP REGISTER registration mechan-

ism.

Expire Time Shows the time in seconds after which the current registration

becomes invalid and a new registration request is therefore

sent.

SIP Header Field(s) for

Caller Address This option defines where and how the DDI sender (caller) ad-

dress is sent for outgoing calls.

Select . The sender address is

transferred to the SIP header in the Displayfield and in the

User field.

In the Advanced Settings menu, perform the settings for the SIP protocol and other spe-

cific settings.

In the Codec Settings submenu you can define which codecs are used for the selected

account.

Note

The codecs actually used are the intersect of the codecs defined here and those sig-

nalled by the provider. For outgoing calls, any remaining codecs are dropped from the

list that would require more than the available bandwidth.

Some fields are optional and only have to be set if required for the corresponding account.

Relevant fields in the menu Advanced Settings

Field Meaning

Codec Proposal Se-

quence Determine the order in which the codecs are offered for use by
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Field Meaning

the media gateway. If the first codec cannot be used, the

second is tried and so on.

Select . As a result, the bintec media gateway

gives preference to compressing codecs in order to occupy as

little bandwidth as possible for the VoIP connections (RTP

streams).

Sort Order Select the codecs to be proposed for the connection.

Echo cancellation Enable or disable echo cancellation. If is selected,

echo feedback is suppressed.

Comfort Noise Genera-

tion (CNG) Specify whether Comfort Noise Generation should be used. The

slight comfort noise generation prevents subscribers from think-

ing that the connection is lost during pauses.

Packet Size The transmission time of an RTP data packet in milliseconds.

Possible values: 10 ... 60.

If registration with the VoIP provider is successful, the status in the provider menu shows

. The status of the VoIP connection is changed by pressing the button or button in

the Action column.

(1) Go to VoIP -> Media Gateway -> SIP Accounts.

Fig. 31: VoIP -> Media Gateway -> SIP Accounts

3.2.3 Extension Assignment / Translation / Call Routing

In the Call Routing menu, the destination number determines which line is used to route

incoming and outgoing calls.

Since the external numbers of the ISDN PABX differ from the extensions used for the ex-

ternal QSC SIP trunking account and the ISDN backup line, the extensions must first be
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translated.

Fig. 32: Extension numbers

PBX Configuration

You can configure the PBX functions for the media gateway in the menu VoIP -> Media

Gateway -> Options.

Incoming and outgoing calls are managed and terminated by the bintec R4100 using the

Session Border Controller and Media Stream Termination settings shown.

(1) Go to VoIP -> Media Gateway -> Options.

Fig. 33: VoIP -> Media Gateway -> Options

Relevant fields in the Options menu

Field Meaning

Session Border Control-

ler Mode Determines the behaviour of the media gateway in combination

with a session border controller.

• : for all extensions that exactly agree with an existing ac-

count, the call routing is handled by the session border con-

troller, i.e. all SIP messages configured for the corresponding

account are forwarded to the session border controller. For all
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Field Meaning

other extensions, call routing is handled by the media gate-

way in accordance with the configured call routing entries.

Note that the call routing is handled by the media gateway if

the provider is not available (backup).

• : call routing is handles exclusively by the media gateway

in accordance with the configured call routing and the local

extensions. For calls that are to be routed via a particular pro-

vider (account), you must configure a corresponding call rout-

ing entry. Internal calls (from internal extension to internal ex-

tension) that are only to be routed internally do not require an

additional call routing entry.

Media Stream Termina-

tion Determines how RTP sessions are controlled by the system.

• : RTP sessions are terminated on the media gate-

way, i.e. all RTP streams are controlled by the media gateway

and routed via the media gateway. The participating terminal

devices (e.g. SIP telephones) are not connected directly with

one another.

Note that, for VoIP to VoIP connections, there is no code

translation for different VoIP terminal codecs. This is why the

codecs from media gateway and VoIP terminals must match;

the RTP sessions are not terminated on the media gateway,

i.e. all RTP streams are routed from the media gateway

without termination. The RTP data packets can be routed in

complex networks and thus also via other gateways.

• (default value): RTP sessions are not terminated

on the media gateway, i.e. all RTP streams are routed by the

media gateway without termination. The RTP data packets

can be routed in complex networks and thus also via other

gateways.

Dialling break Shows the maximum delay time before the system assumes the

telephone number entered is complete and starts the SIP dial-

ling process (sends the SIP INVITE message). This timeout is

reset each time that a button is pressed. Default value: .

Call Translation

The ISDN PBX uses the master subscriber number 9673 on the external connection and a

two-digit extension block (00-99), which indicates the respective extension.
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In this example, an incoming call via the QSC SIP trunk is signalled to the media gateway

with the called party number (destination number) 06227899154 and the two-digit direct di-

alling range number (00-99). For the incoming call to be transferred successfully, the media

gateway must change this called party number from 06227899154 [extension number] to

9673 [extension number].

With an outgoing call, the ISDN PBX signals to the media gateway the calling party number

(subscriber number of the caller) 9673 with an attached extension number. The media

gateway then initiates an outgoing call over the QSC SIP trunk and uses the number

06227899154 [extension] as the calling party number.

You can configure how called party numbers for incoming calls and calling party numbers

for outgoing calls are translated in the Call Translation menu.

(1) Go to VoIP -> Media Gateway -> Call Translation -> New.

Fig. 34: VoIP -> Media Gateway -> Call Translation -> New

Relevant fields in the Call Translation menu

Field Meaning

Description Give the number translation a name.

Direction
Here you enter the direction to which the entry is to apply.

Select for incoming and outgoing calls (bidirectional).

Associated Line Determines the line or SIP account via which the calls are to be

routed.

Local Address
Here you enter the internal number (e.g. extension or PBX num-

ber).

For outgoing calls, the signalled Calling Party Number

(corresponds in the menu to the Local Address field) is trans-

lated to the External Address.
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Field Meaning

Numerical and alphanumerical characters are permissible.

? is a placeholder for an arbitrary digit.

Note Local Address and External Address must contain the

same number of wildcards.

External Address Enter the external number here. For outgoing calls, the sig-

nalled called party number (corresponding in the menu to the

Local Address field) is translated to the External Address.

Call translation between ISDN PBX and the ISDN backup line function according to the

same principle. For example, with an incoming call over the ISDN backup line, called party

number 7660069-20 is translated to called party number 9673-20 and then signalled to the

ISDN PBX by the call routing. For example, with an outgoing call calling party, number

9673-20 is translated to calling party number 7660069-20 and then signalled over the ISDN

backup line using call routing.

(1) Go to VoIP -> Media Gateway -> Call Translation -> New.

Fig. 35: VoIP -> Media Gateway -> Call Translation -> New

3.2.4 Translating the calling party number (CLID)

In the CLID Translation menu, you define the processing of the (calling party number) for

incoming calls. You can, for example, add a prefix to a received call number in order to

route corresponding outgoing calls via a particular account.

If the ISDN PBX for outgoing connections requires a specific dialling code for the trunk pre-

fix (e.g. a leading 0), the calling party number must also be changed for incoming calls. The

calling party number must be changed to enable a callback directly from the caller list of a

telephone. If an incoming call is signalled from extension 091196730, for example, the call-

ing party number of the caller must be displayed on the telephone with a leading zero (e.g.

0091196730). This change to the calling party number (for incoming calls) can be con-
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figured in the CLID Translation menu.

The following chapter describes how to change the calling party number for calls signalled

over the QSC SIP trunking account.

(1) Go to VoIP -> Media Gateway -> CLID Translation -> New.

Fig. 36: VoIP -> Media Gateway -> CLID Translation -> New

This section describes how to change the calling party number for calls signalled over the

ISDN backup line.

(1) Go to VoIP -> Media Gateway -> CLID Translation -> New.

Fig. 37: VoIP -> Media Gateway -> CLID Translation -> New

Relevant fields in the CLID Translation menu

Field Meaning

Description Give the entry a name.

Call number Select the line or SIP account via which the calls are to be

routed.

Called Line
Here you enter the direction to which the entry is to apply.

Select for incoming and outgoing calls (bidirectional).
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Field Meaning

Calling Address Transla-

tion Transformation rule to be used on the subscriber number

The calling party number transmitted by the provider is pre-

ceded with a leading zero according to the rule mechanism.

Configuration of call routing

In the Call Routing menu, there occurs a definition of which SIP account or ISDN line is

used when establishing a new call. Two entries are required to convert the extension num-

bers shown above.

Note

In principle, care must be taken when configuring call routing that the rules for call

translation take priority over call routing. This means that the numbers converted after

the call translation must be taken into account in the call routing menu.

With incoming calls, the called party number is changed using call translation to 9673 (main

number of the ISDN PBX) with the attached extension number (e.g. 9673-20). The follow-

ing call routing entry routes all calls with a destination number starting with 9673 to ISDN

Port bri2-3 and therefore to the ISDN PBX.

(1) Go to VoIP -> Media Gateway -> Call Routing -> New.

Fig. 38: VoIP -> Media Gateway -> Call Routing -> New

Relevant fields in the Call Routing menu
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Field Meaning

Description Here you give the entry a name.

Administrative Status The entry is used with .

Type Select for calls that are routed to a PBX behind the me-

dia gateway.

Calling Line Here you can restrict the routing entry to the line on which the

call comes in.

Called Address
Here you can enter an address numerically (e.g. a subscriber

number) or alphanumerically (e.g. for a trunk) that is to be com-

pared with a dialled address. You can use wildcards.

* means that at the end of a character string any number of

characters may follow,

If the configured address agrees with the signalled address, the

routing entry is used.

Trunk Line Defines the ISDN port for a call routed to the ISDN PBX.

An additional entry is required for outgoing connections. If wildcards "*" are used in the

Called Address option, all outgoing calls are routed via the SIP accounts/ISDN lines listed

in the table. In the following configuration the media gateway mainly initiates outgoing con-

nections over the QSC SIP trunk (Order 1). If the QSC SIP trunk fails (e.g. due to a failed

SIP registration) the outgoing calls are routed over the ISDN backup line (Order 2).

The following section shows the call routing entries that are required for outgoing connec-

tions.

(1) Go to VoIP -> Media Gateway -> Call Routing -> New.
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Fig. 39: VoIP -> Media Gateway -> Call Routing -> New

Relevant fields in the Call Routing menu

Field Meaning

Description Here you give the entry a name.

Administrative Status The entry is used with .

Type Select for calls that are to be routed as outgoing ex-

ternal calls. This can be done using standard SIP accounts or

SIP trunking accounts in DDI client mode.

Calling Line Here you can restrict the routing entry to the line on which the

call comes in.

Called Address Here you can enter an address that is compared with the dialled

address. You can use wildcards. If wildcards * are used in the

Called Address option, all calls that cannot be handled by an-

other call routing are routed via the SIP accounts/ISDN lines lis-

ted in the table.

You can now create a list with connections over which outgoing calls can be sent. If the line

(SIP provider or ISDN line) cannot be used with Order 1, the line with the next highest or-

der will be used to establish the connection.

Use Add to create entries.

Relevant fields in the Routing Rule menu
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Field Meaning

Priority Determines the order of the filter rules, starting with in in-

creasing numerical order.

Administrative Status The entry is used with .

Outbound Line Defines the PSTN line (PRI, BRI, FXO) or the SIP account used

for an outgoing call.

3.2.5 Enabling the Application Level Gateway for dynamic

monitoring of the NAT and firewall instance

To enable IP telephones to connect by SIP to a VoIP Provider your device has an Applica-

tion Level Gateway (ALG), i.e. an appropriate proxy that implements the necessary NAPT

and firewall releases.

In our example the media gateway is connected to the internet over an ADSL path. For se-

curity reasons Network Address Translation and the Stateful Inspection Firewall have

been enabled. The Application Level Gateway must be enabled to prevent any negative

interference by the firewall to VoIP calls (e.g. blocking the RTP stream). During a VoIP call

the Application Level Gateway dynamically authorises access to the internet for the re-

quired SIP and RTP connections.

In the ex works state two proxy entries are predefined for the SIP Application Level Gate-

way.

(1) Go to VoIP -> Application Level Gateway ->SIP Proxies.

Fig. 40: VoIP -> Application Level Gateway -> SIP Proxies

In our example the proxy entry is enabled.

(1) Go to VoIP -> Application Level Gateway -> <SIP UDP 5060> .
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Fig. 41: VoIP -> Application Level Gateway -> <SIP UDP 5060>

Relevant fields in the SIP Proxy menu

Field Meaning

Description Name of the proxy entry.

Administrative Status Set Administrative Status to .

Protocol Defines the protocol to be used.

Destination Port Here you enter the port to be supervised by the proxy.

Session Timeout Shows the time in seconds for which a session stays up if no

data packets are sent or received.

Low Latency Transmis-

sion Mechanism to minimise the transit time of VoIP data packets

between two subscribers. This guarantees good voice quality

with high line load.

Note that Low Latency Transmission does not have to be

switched on if the media gateway supervises the VoIP connec-

tion.

If , the voice quality is optimised, if , the

voice quality is not optimised.

Real Time Jitter Control

For telephone calls over the Internet, VoIP packets normally have the highest priority. Nev-

ertheless, if the upstream bandwidth is low, noticeable delays in voice transmission can oc-

cur when other packets are routed at the same time. The Real Time Jitter Control func-

tion in the VoIP implementation solves this problem. So as not to block the "line" for VoIP

packets for too long, the size of other data packets is reduced if need be during a tele-

phone call.
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Note

When using the media gateway, Control Mode should always be set on

.

(1) Go to WAN -> Real Time Jitter Control -> Controlled Interfaces -> New.

Fig. 42: WAN -> Real Time Jitter Control -> Controlled Interfaces -> New

Relevant fields in the Controlled Interfaces menu

Field Meaning

Interface Here you select the connection on which the voice transmission

is to be optimised.

Control Mode
Select the mode for the optimisation.

Select : By means of the

data routed through the media gateway, the system recognises

VoIP data traffic and optimises the voice transmission. This set-

ting should always be used together with the media gateway.

Maximum Upload Speed If you use an external DSL modem, you must enter the band-

width.
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3.3 Overview of configuration steps

Configuring the external ISDN interface

Field Menu Value

Port Name Physical Interfaces -> ISDN

Ports -> <bri2-0 (TE)>

Autoconfiguration on Bootup Physical Interfaces -> ISDN

Ports -> <bri2-0 (TE)>

Result of Autoconfiguration Physical Interfaces -> ISDN

Ports -> <bri2-0 (TE)>

Port Name Physical interfaces -> ISDN

Ports -> <bri2-1 (NT)>

Port Usage Physical interfaces -> ISDN

Ports -> <bri2-1 (NT)>

ISDN Configuration Type Physical interfaces -> ISDN

Ports -> <bri2-1 (NT)>

Configuration of SIP accounts

Field Menu Value

Description VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

Administrative Status VoIP -> Media Gateway ->

SIP Accounts -> New

Trunk Mode VoIP -> Media Gateway ->

SIP Accounts -> New

Registrar VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

Protocol VoIP -> Media Gateway ->

SIP Accounts -> New

Port VoIP -> Media Gateway ->

SIP Accounts -> New

User Name VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

Password VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.
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Field Menu Value

Registration VoIP -> Media Gateway ->

SIP Accounts -> New

Expire Time VoIP -> Media Gateway ->

SIP Accounts -> New

e.g. sec

SIP Header Field(s) for

Caller Address

VoIP -> Media Gateway ->

SIP Accounts -> New

Codec Proposal Sequence VoIP -> Media Gateway ->

SIP Accounts -> New-> Ad-

vanced Settings

Echo cancellation VoIP -> Media Gateway ->

SIP Accounts -> New-> Ad-

vanced Settings

Comfort Noise Generation VoIP -> Media Gateway ->

SIP Accounts -> New-> Ad-

vanced Settings

Packet Size VoIP -> Media Gateway ->

SIP Accounts -> New-> Ad-

vanced Settings

ms

Call Assignment

Field Menu Value

Session Border Controller

Mode

VoIP -> Media Gateway ->

Options

Media Stream Termination VoIP -> Media Gateway ->

Options

Dialling break VoIP -> Media Gateway ->

Options

e.g. seconds

Call Translation

Field Menu Value

Description VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Direction VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Associated Line VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Local Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.
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Field Menu Value

External Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Description VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Direction VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Associated Line VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Local Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

External Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Configuration of CLID translation

Field Menu Value

Description VoIP -> Media Gateway ->

CLID Translation -> New

e.g.

Call number VoIP -> Media Gateway ->

CLID Translation -> New

Called Line VoIP -> Media Gateway ->

CLID Translation -> New

Calling Address Translation VoIP -> Media Gateway ->

CLID Translation -> New

e.g.

Description VoIP -> Media Gateway ->

CLID Translation -> New

e.g.

Call number VoIP -> Media Gateway ->

CLID Translation -> New

e.g.

Called Line VoIP -> Media Gateway ->

CLID Translation -> New

Calling Address Translation VoIP -> Media Gateway ->

CLID Translation -> New

e.g.

Configuration of call routing

Field Menu Value

Description VoIP -> Media Gateway ->

Call Routing -> New

e.g.

Administrative Status VoIP -> Media Gateway ->

Call Routing -> New
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Field Menu Value

Type VoIP -> Media Gateway ->

Call Routing -> New

Calling Line VoIP -> Media Gateway ->

Call Routing -> New

Called Address VoIP -> Media Gateway ->

Call Routing -> New

e.g.

Trunk Line VoIP -> Media Gateway ->

Call Routing -> New

e.g.

Description VoIP -> Media Gateway ->

Call Routing -> New

e.g.

Administrative Status VoIP -> Media Gateway ->

Call Routing -> New

Type VoIP -> Media Gateway ->

Call Routing -> New

Calling Line VoIP -> Media Gateway ->

Call Routing -> New

Called Address VoIP -> Media Gateway ->

Call Routing -> New

e.g.

Priority VoIP -> Media Gateway ->

Call Routing -> New-> Add

Administrative Status VoIP -> Media Gateway ->

Call Routing -> New-> Add

Outbound Line VoIP -> Media Gateway ->

Call Routing -> New-> Add

e.g.

Priority VoIP -> Media Gateway ->

Call Routing -> New-> Add

Administrative Status VoIP -> Media Gateway ->

Call Routing -> New-> Add

Outbound Line VoIP -> Media Gateway ->

Call Routing -> New-> Add

e.g.

Application Level Gateway

Field Menu Value

Description VoIP -> Application Level

Gateway -> <SIP UDP

5060>

e.g.

Administrative Status VoIP -> Application Level
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Field Menu Value

Gateway -> <SIP UDP

5060>

Protocol VoIP -> Application Level

Gateway -> <SIP UDP

5060>

Destination Port VoIP -> Application Level

Gateway -> <SIP UDP

5060>

Session Timeout VoIP -> Application Level

Gateway -> <SIP UDP

5060>

Low Latency Transmission VoIP -> Application Level

Gateway -> <SIP UDP

5060>

Real Time Jitter Control

Field Menu Value

Interface WAN -> Real Time Jitter

Control -> Controlled Inter-

faces -> New

e.g.

Control Mode WAN -> Real Time Jitter

Control -> Controlled Inter-

faces -> New

Maximum Upload Speed WAN -> Real Time Jitter

Control -> Controlled Inter-

faces -> New

e.g. kbit/s
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Chapter 4 Media Gateway - Configuring the

connection of an ISDN PABX to a SIP trunking

account with provider Toplink

4.1 Introduction

The following chapters describe how to configure a bintec R4100 as a media gateway to

connect an ISDN PBX to a Toplink SIP trunking account. The ISDN PBX has been set up

for operation on a point-to-point ISDN access.

In our example, the main number for the point-to-point ISDN access 9673 and the direct di-

alling range numbers of the extensions is a two-digit number. The PABX is connected to

the media gateway over an ISDN port. The second ISDN port of the media gateway is con-

nected with an exchange-based point-to-point ISDN access and serves as an ISDN backup

line.

Fig. 43: Example scenario

Requirements

The following are required for the configuration:

• A bintec media gateway with system software 7.6.6.

• A DSP module (4-way) must be installed

• An Internet connection with sufficient bandwidth (recommended uplink bandwidth >= 256

kbp/s)

Configuration in this scenario is carried out using the GUI (Graphical User Interface) .

bintec elmeg GmbH 4 Media Gateway - Configuring the connection of an ISDN

PABX to a SIP trunking account with provider Toplink

Workshops (Excerpt) 69



4.2 Configuration

4.2.1 Configuring the ISDN interfaces

ISDN port ISDN-0 on bintec R4100 is connected to the NTBA (Network Termination Basis

Connection) of the ISDN backup line. The ISDN ports of the media gateway are already en-

abled in ISDN TE mode in the ex works state and the ISDN switch type is recognised auto-

matically when starting the media gateway. As a result, no changes have to be made for

this ISDN port.

(1) Go to Physical Interfaces -> ISDN Ports -> ISDN Configuration -> <bri2-0 (TE)

Fig. 44: Physical Interfaces -> ISDN Ports -> ISDN Configuration -> <bri2-0 (TE)

ISDN mode must be changed to before the ISDN PBX can connect to the media

gateway at port . To do this, the housing on the media gateway must be opened.

The link plugs for the ISDN-0 and ISDN-1 interfaces can be found on all devices on the

main PCB behind the ISDN terminal block.

Insert the link plugs for interfaces ISDN-0 and ISDN-1 as follows:

Internal/external switching J0M External (factory default setting)

Internal/external switching J1M internal

Power supply J0P Off (factory default setting)

Power supply J1P On

Terminator J0T Off (factory default setting)

Terminator J1T On

For further information on setting the ISDN interfaces see Release Notes 7.5.1 (Chapter:

2.2 Variable switching for ISDN S0 interfaces).
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Once the interface has been set by changing the link plugs to ISDN NT mode, you

can configure the port for connecting the PBX. As the PBX has been configured for opera-

tion on a point-to-point ISDN access, you must set the ISDN Configuration Type to

on the media gateway.

(1) Go to Physical Interfaces -> ISDN Ports -> ISDN Configuration -> <bri2-1 (NT)

Fig. 45: Physical Interfaces -> ISDN Ports -> ISDN Configuration -> <bri2-1 (NT)

Relevant fields in the ISDN Configuration menu

Field Meaning

Port Name Shows the name of the ISDN port.

Port Usage Select the protocol that you want to use for the ISDN port.

ISDN Configuration

Type

Here, select ISDN access configuration .

4.2.2 Configuring the Toplink SIP trunking accounts

The login data for registering the SIP trunking accounts with provider Toplink are entered in

the SIP Accounts menu. To create the account, add a new entry and configure the ac-

count as indicated below.

In the Trunk Settings submenu, you can define the settings for direct dial-in. An incoming

call can be routed to just one terminal device (direct dial-in). For an outgoing call, the caller

can be indicated to the called party.

The following settings ensures that your own subscriber number is transmitted correctly

with outgoing calls. With a Toplink SIP trunking account, your own subscriber number (with

attached direct dialling range number) is indicated in the SIP header field for caller address

.

(1) Go to VoIP -> Media Gateway -> SIP Accounts-> New.
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Fig. 46: VoIP -> Media Gateway -> SIP Accounts -> New

Relevant fields in the SIP Accounts menu

Field Meaning

Description Here, assign a name to the account. Maximum number of char-

acters: 40.

Administrative Status Enable the administrative status of the account.

Trunk Mode Select the trunk mode to be used. If you select , the me-

dia gateway is run as a SIP client.

Registrar Here, enter the IP address of the SIP registrar or of the SIP

proxy server. Maximum number of characters: 40.

Protocol Select the protocol to be used for data transport.

Port Number of the TCP or UDP port to be used for the connection

to the server or proxy.
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Field Meaning

User Name Here, enter the username for authentication if your VoIP pro-

vider has assigned one to you.

Authentication ID Enter a name that is to be used for authentication. If you do not

enter a name, the name in the User Name field is used.

Password The VoIP provider gives you a PIN or password for authentica-

tion. You must enter this value here. Maximum number of char-

acters: 40.

Registration Enables or disables the SIP REGISTER registration mechan-

ism.

Expire Time Shows the time in seconds after which the current registration

becomes invalid and a new registration request is therefore

sent.

SIP Header Field(s) for

Caller Address This option defines where and how the DDI sender (caller) ad-

dress is sent for outgoing calls.

Select . The so-called "p-preferred-identity" field

is added to the SIP header and contains the sender address.

In the Advanced Settings menu, perform the settings for the SIP protocol and other spe-

cific settings.

In the Codec Settings submenu you can define which codecs are used for the selected

account.

Note

The codecs actually used are the intersect of the codecs defined here and those sig-

nalled by the provider. For outgoing calls, any remaining codecs are dropped from the

list that would require more than the available bandwidth.

Some fields are optional and only have to be set if required for the corresponding account.

Relevant fields in the menu Advanced Settings

Field Meaning

Codec Proposal Se-

quence Determine the order in which the codecs are offered for use by

the media gateway. If the first codec cannot be used, the

second is tried and so on.

Select . As a result, the bintec media gateway

gives preference to compressing codecs in order to occupy as
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Field Meaning

little bandwidth as possible for the VoIP connections (RTP

streams).

Sort Order Select the codecs to be proposed for the connection.

Echo cancellation Enable or disable echo cancellation. If is selected,

echo feedback is suppressed.

Comfort Noise Genera-

tion (CNG) Specify whether Comfort Noise Generation should be used. The

slight comfort noise generation prevents subscribers from think-

ing that the connection is lost during pauses.

Packet Size The transmission time of an RTP data packet in milliseconds.

Possible values: 10 ... 60.

If registration with the VoIP provider is successful, the status in the provider menu shows

. The status of the VoIP connection is changed by pressing the button or button in

the Action column.

(1) Go to VoIP -> Media Gateway -> SIP Accounts.

Fig. 47: VoIP -> Media Gateway -> SIP Accounts

4.2.3 Extension Assignment / Translation / Call Routing

In the Call Routing menu, the destination number determines which line is used to route

incoming and outgoing calls.

Since the external numbers of the ISDN PBX differ from the extensions used for the

Toplink SIP trunking account and the ISDN backup line, the extensions must first be trans-

lated.
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Fig. 48: Extension numbers

Call Translation

The ISDN PBX uses the master subscriber number 9673 on the external ISDN port and a

two-digit extension block (00-99), which indicates the respective extension.

The Toplink SIP trunking account used in this example allows up to 10 extensions to be

connected with a one-digit direct dialling range number. In this example the following exten-

sions have been connected to the ISDN PBX: 10, 11, 12, 13, 14, 15, 50, 80, 99.

An incoming call via the Toplink SIP trunking account is signalled to the media gateway

with the called party number (destination number) +49911647494 and a one-digit direct di-

alling range number (0-9). For the call to be transferred successfully, the media gateway

must change this called party number from +49911647494 [extension number] to 9673

[extension number]. With an outgoing call, the ISDN PBX signals to the media gateway the

calling party number (subscriber number of the caller) 9673 with an attached extension

number (00-99). The media gateway then initiates an outgoing call over the Toplink SIP

trunking account and uses the calling party number +49911647494 with the attached one-

digit extension number [0-9].

In this example the ISDN PBX uses a two-digit extension number block (9673[00-99]) to

refer to the respective extension for the external subscriber number. The Toplink SIP trunk-

ing account, however, only provides a one-digit extension number block

(+49911647494[0-9]). Consequently, the number of the respective extension cannot be

transferred exactly for incoming and outgoing calls.

The following configuration is required for the extension number translation described:

The translation of the subscriber numbers for extensions 10 to 15 can be configured with a

single Call Translation entry. This simplified method is achieved by using a placeholder

('?'). The configuration shown in this example translates the called party number

+49911647494-1 to extension number 9673-11, for example, for an incoming call. With an

outgoing call initiated from extension 11, this entry allows the calling party number to be
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translated from 9673-11 to +49911647494-1. The call translation function always retains

the last digit of the dialled subscriber number for incoming calls, and replaces the previous

digits of the subscriber number.

(1) Go to VoIP -> Media Gateway -> Call Translation ->New.

Fig. 49: VoIP -> Media Gateway -> Call Translation ->New

Relevant fields in the Call Translation menu

Field Meaning

Description Give the number translation a name.

Direction
Here you enter the direction to which the entry is to apply.

Select for incoming and outgoing calls (bidirectional).

Associated Line Determines the line or SIP account via which the calls are to be

routed.

Local Address
Here you enter the internal number (e.g. extension or PBX num-

ber).

For outgoing calls, the signalled Calling Party Number

(corresponds in the menu to the Local Address field) is trans-

lated to the External Address.

Numerical and alphanumerical characters are permissible.

? is a placeholder for an arbitrary digit.

Note Local Address and External Address must contain the

same number of wildcards.

External Address Enter the external number here. For outgoing calls, the sig-

nalled called party number (corresponding in the menu to the

Local Address field) is translated to the External Address.
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A similar entry is required to translate numbers between the ISDN PBX and the ISDN

backup line. For example, with an incoming call the called party number 76600691 is trans-

lated to 967311 and then signalled to the ISDN PBX by the call translation. With an outgo-

ing call initiated from extension 11, this call translation configuration translates the calling

party number from 967311 to 76600691.

(1) Go to VoIP -> Media Gateway -> Call Translation ->New.

Fig. 50: VoIP -> Media Gateway -> Call Translation ->New

Placeholders cannot be used to create the call translation entries for the other direct dial-

ling range numbers used in this example. You must therefore create your own call transla-

tion entry for each extension.

The following chapter describes how to configure Call Translation for extensions 50, 80

and 99.

The following call translation configuration translates the calling party number 967350 to

+499116474946 when making outgoing calls. With incoming calls, the called party number

is changed accordingly.

(1) Go to VoIP -> Media Gateway -> Call Translation ->New.

Fig. 51: VoIP -> Media Gateway -> Call Translation ->New

The following call translation configuration translates the calling party number 967350 to
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76600696 when making outgoing calls. With incoming calls, the called party number is

changed accordingly.

(1) Go to VoIP -> Media Gateway -> Call Translation ->New.

Fig. 52: VoIP -> Media Gateway -> Call Translation ->New

The following call translation configuration translates the calling party number 967380 to

+499116474947 when making outgoing calls. With incoming calls, the called party number

is changed accordingly.

(1) Go to VoIP -> Media Gateway -> Call Translation ->New.

Fig. 53: VoIP -> Media Gateway -> Call Translation ->New

The following call translation configuration translates the calling party number 967380 to

76600697 when making outgoing calls. With incoming calls, the called party number is

changed accordingly.

(1) Go to VoIP -> Media Gateway -> Call Translation ->New.
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Fig. 54: VoIP -> Media Gateway -> Call Translation ->New

The following call translation configuration translates the calling party number 967399 to

+499116474948 when making outgoing calls. With incoming calls, the called party number

is changed accordingly.

(1) Go to VoIP -> Media Gateway -> Call Translation ->New.

Fig. 55: VoIP -> Media Gateway -> Call Translation ->New

The following call translation configuration translates the calling party number 967399 to

76600698 when making outgoing calls. With incoming calls, the called party number is

changed accordingly.

(1) Go to VoIP -> Media Gateway -> Call Translation ->New.
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Fig. 56: VoIP -> Media Gateway -> Call Translation ->New

The complete configuration then looks like this:

(1) Go to VoIP -> Media Gateway -> Call Translation .

Fig. 57: VoIP -> Media Gateway -> Call translation

4.2.4 Translating the calling party number (CLID)

If the ISDN PBX for outgoing connections requires a specific dialling code for the trunk pre-

fix (e.g. a leading 0), the calling party number must also be changed for incoming calls. The

calling party number must be changed to enable a callback directly from the caller list of a

telephone.

If an incoming call is signalled from extension 091196730, for example, the calling party

number of the caller must be displayed on the telephone with a leading zero (e.g.

0091196730). This change to the calling party number (for incoming calls) can be con-

figured in the CLID Translation menu.

The following chapter describes how to change the calling party number for incoming calls

over the Toplink SIP trunk. The calling party number (e.g. 091196730) transmitted by the

provider is preceded with a leading zero (e.g. 0091196730) according to the rule mechan-

ism.
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(1) Go to VoIP -> Media Gateway -> CLID Translation -> New.

Fig. 58: VoIP -> Media Gateway -> CLID Translation -> New

This section describes how to change the calling party number for incoming calls over the

ISDN backup line.

(1) Go to VoIP -> Media Gateway -> CLID Translation -> New.

Fig. 59: VoIP -> Media Gateway -> CLID Translation -> New

Relevant fields in the CLID Translation menu

Field Meaning

Description Here, enter the name of the CLID translation entry.

Call number Select the line or SIP account via which the calls are to be

routed.

Called Line
Here you enter the direction to which the entry is to apply.

Select for incoming and outgoing calls (bidirectional).

Called Address Here you have the option of entering the destination address of

the call.

Calling Address Transla-

tion Enter the transformation rule applied to the call numbers.
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Field Meaning

The calling party number transmitted by the provider is pre-

ceded with a leading zero according to the rule mechanism.

Configuration of call routing

In the Call Routing menu, there is a definition of which SIP account or ISDN line is used

when establishing a call.

Note

In principle, care must be taken when configuring call routing that the rules for call

translation take priority over call routing. This means that the numbers converted after

the call translation must be taken into account in the call routing menu.

Two entries are required to convert the extension numbers shown above.

With incoming calls, the called party number is changed using the call translation mechan-

ism to 9673 (master subscriber number of the ISDN PBX) with attached extension number

(e.g. 967311). The following call routing configuration routes all calls with a destination

number starting with 9673 to ISDN port bri2-1, and therefore to the ISDN PBX.

(1) Go to VoIP -> Media Gateway -> Call Routing -> New.

Fig. 60: VoIP -> Media Gateway -> Call Routing -> New

Relevant fields in the Call Routing menu

Field Meaning

Description Here you give the entry a name.
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Field Meaning

Administrative Status The entry is used with .

Type Select for calls that are routed to a PBX behind the me-

dia gateway.

Called Line
Here you enter the direction to which the entry is to apply.

Select for incoming and outgoing calls (bidirectional).

Called Address
Here you can enter an address numerically (e.g. a subscriber

number) or alphanumerically (e.g. for a trunk) that is to be com-

pared with a dialled address. You can use wildcards.

* means that at the end of a character string any number of

characters may follow,

If the configured address agrees with the signalled address, the

routing entry is used.

Trunk Line Defines the ISDN port for a call routed to the ISDN PBX.

An additional call routing entry is required for outgoing connections. If wildcards "*" are

used in the Called Address option, all outgoing calls are routed via the SIP accounts/ISDN

lines listed in the table. In the following configuration the media gateway mainly initiates

outgoing connections over the Toplink SIP trunking account (Order 1). If the Toplink SIP

trunking account fails (e.g. due to a failed SIP registration) the outgoing calls are routed

over the ISDN backup line (Order 2).

The following section shows the call routing entries that are required for outgoing connec-

tions.

(1) Go to VoIP -> Media Gateway -> Call Routing -> New.
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Fig. 61: VoIP -> Media Gateway -> Call Routing -> New

Relevant fields in the Call Routing menu

Field Meaning

Description Here you give the entry a name.

Administrative Status The entry is used with .

Type Select for calls that are to be routed as outgoing ex-

ternal calls. This can be done using standard SIP accounts or

SIP trunking accounts in DDI client mode.

Calling Line
Here you enter the direction to which the entry is to apply.

Select for incoming and outgoing calls (bidirectional).

Called Address Here you can enter an address that is compared with the dialled

address. You can use wildcards. If wildcards * are used in the

Called Address option, all calls that cannot be handled by an-

other call routing are routed via the SIP accounts/ISDN lines lis-

ted in the table.

You can now create a list with connections over which outgoing calls can be sent. If the line

(SIP provider or ISDN line) cannot be used with Order 1, the line with the next highest or-

der will be used to establish the connection.

Use Add to create entries.
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Relevant fields in the Routing Rule menu

Field Meaning

Priority Determines the order of the filter rules, starting with in in-

creasing numerical order.

Admin Status The entry is used with .

Outbound Line Defines the PSTN line (PRI, BRI, FXO) or the SIP account used

for an outgoing call.

4.2.5 Enabling the Application Level Gateway for dynamic

monitoring of the NAT and firewall instance

To enable IP telephones to connect by SIP to a VoIP Provider your device has an Applica-

tion Level Gateway (ALG), i.e. an appropriate proxy that implements the necessary NAPT

and firewall releases.

In our example the media gateway is connected to the internet over an ADSL path. For se-

curity reasons Network Address Translation and the Stateful Inspection Firewall have

been enabled. The Application Level Gateway must be enabled to prevent any negative

interference by the firewall to VoIP calls (e.g. blocking the RTP stream). During a VoIP call

the Application Level Gateway dynamically authorises access to the internet for the re-

quired SIP and RTP connections.

In the ex works state two proxy entries are predefined for the SIP Application Level Gate-

way.

In our example the proxy entry is enabled.

(1) Go to VoIP -> Application Level Gateway -> SIP-Proxies -> <SIP UDP 5060> .

Fig. 62: VoIP -> Application Level Gateway -> SIP-Proxies -> <SIP UDP 5060>

Relevant fields in the SIP Proxies menu
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Field Meaning

Description Name of the proxy entry.

Administrative Status Set Administrative Status to .

Protocol Defines the protocol to be used.

Destination Port Here you enter the port to be supervised by the proxy.

Session Timeout Shows the time in seconds for which a session stays up if no

data packets are sent or received.

Low Latency Transmis-

sion Mechanism to minimise the transit time of VoIP data packets

between two subscribers. This guarantees good voice quality

with high line load.

Note that Low Latency Transmission does not have to be

switched on if the media gateway supervises the VoIP connec-

tion.

If , the voice quality is optimised, if , the

voice quality is not optimised.

Real Time Jitter Control

If the internet connection of the router is used for other internet traffic or VPN connections

in addition to VoIP data traffic, the QoS mechanism should be enabled. If the upload band-

width of the Internet connection is under 1 Mbps, the Controlled Interface mechanism

should also be enabled. The Controlled Interface function fragments the remaining

(non-VoIP) traffic to prevent breaks in VoIP calls. If the internal ADSL modem of the router

is not used, the maximum upload bandwidth must be configured manually. In this example

an upload bandwidth of 512 kbps is used. Configuring the Controlled Interface function

automatically enables the QoS mechanism.

Note

When using the media gateway, Control Mode should always be set on

.

(1) Go to WAN -> Real Time Jitter Control -> Controlled Interfaces -> New.
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Fig. 63: WAN -> Real Time Jitter Control -> Controlled Interfaces -> New

Relevant fields in the Controlled Interfaces menu

Field Meaning

Interface Here you select the connection on which the voice transmission

is to be optimised.

Control Mode
Select the mode for the optimisation.

Select : By means of the

data routed through the media gateway, the system recognises

VoIP data traffic and optimises the voice transmission. This set-

ting should always be used together with the media gateway.

Maximum Upload Speed Enter the maximum available upstream bandwidth in kbp/s for

the selected interface.
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4.3 Overview of configuration steps

Configuring the external ISDN interface

Field Menu Value

Port Name Physical Interfaces -> ISDN

Ports -> <bri2-0 (TE)>

Autoconfiguration on Bootup Physical Interfaces -> ISDN

Ports -> <bri2-0 (TE)>

Result of Autoconfiguration Physical Interfaces -> ISDN

Ports -> <bri2-0 (TE)>

Port Name Physical interfaces -> ISDN

Ports -> <bri2-1 (NT)>

Port Usage Physical interfaces -> ISDN

Ports -> <bri2-1 (NT)>

ISDN Configuration Type Physical interfaces -> ISDN

Ports -> <bri2-1 (NT)>

Configuration of SIP accounts

Field Menu Value

Description VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

Administrative Status VoIP -> Media Gateway ->

SIP Accounts -> New

Trunk Mode VoIP -> Media Gateway ->

SIP Accounts -> New

Client

Registrar VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

Protocol VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

Port VoIP -> Media Gateway ->

SIP Accounts -> New

User Name VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

Password VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

4 Media Gateway - Configuring the connection of an ISDN

PABX to a SIP trunking account with provider Toplink

bintec elmeg GmbH

88 Workshops (Excerpt)



Field Menu Value

Registration VoIP -> Media Gateway ->

SIP Accounts -> New

Expire Time VoIP -> Media Gateway ->

SIP Accounts -> New

Sec

SIP Header Field(s) for

Caller Address

VoIP -> Media Gateway ->

SIP Accounts -> New

Codec Proposal Sequence VoIP -> Media Gateway ->

SIP Accounts ->New Ad-

vanced Settings

Echo cancellation VoIP -> Media Gateway ->

SIP Accounts ->New Ad-

vanced Settings

Comfort Noise Generation VoIP -> Media Gateway ->

SIP Accounts ->New Ad-

vanced Settings

Packet Size VoIP -> Media Gateway ->

SIP Accounts ->New Ad-

vanced Settings

ms

Call Translation

Field Menu Value

Description VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Direction VoIP -> Media Gateway ->

Call Translation -> New

Associated Line VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Local Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

External Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Description VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Direction VoIP -> Media Gateway ->

Call Translation -> New

Associated Line VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Local Address VoIP -> Media Gateway -> e.g.
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Field Menu Value

Call Translation -> New

External Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Description VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Direction VoIP -> Media Gateway ->

Call Translation -> New

Associated Line VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Local Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

External Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Description VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Direction VoIP -> Media Gateway ->

Call Translation -> New

Associated Line VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Local Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

External Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Description VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Direction VoIP -> Media Gateway ->

Call Translation -> New

Associated Line VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Local Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

External Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Description VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Direction VoIP -> Media Gateway ->

Call Translation -> New
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Field Menu Value

Associated Line VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Local Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

External Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Description VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Direction VoIP -> Media Gateway ->

Call Translation -> New

Associated Line VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Local Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

External Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Description VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Direction VoIP -> Media Gateway ->

Call Translation -> New

Associated Line VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Local Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

External Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Configuration of CLID translation

Field Menu Value

Description VoIP -> Media Gateway ->

CLID Translation -> New

e.g.

Call number VoIP -> Media Gateway ->

CLID Translation -> New

Called Line VoIP -> Media Gateway ->

CLID Translation -> New

Calling Address Translation VoIP -> Media Gateway ->

CLID Translation -> New

e.g.
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Field Menu Value

Description VoIP -> Media Gateway ->

CLID Translation -> New

e.g.

Call number VoIP -> Media Gateway ->

CLID Translation -> New

e.g.

Called Line VoIP -> Media Gateway ->

CLID Translation -> New

Calling Address Translation VoIP -> Media Gateway ->

CLID Translation -> New

e.g.

Configuration of call routing

Field Menu Value

Description VoIP -> Media Gateway ->

Call Routing -> New

e.g.

Administrative Status VoIP -> Media Gateway ->

Call Routing -> New

Type VoIP -> Media Gateway ->

Call Routing -> New

Calling Line VoIP -> Media Gateway ->

Call Routing -> New

Called Address VoIP -> Media Gateway ->

Call Routing -> New

e.g.

Trunk Line VoIP -> Media Gateway ->

Call Routing -> New

e.g.

Description VoIP -> Media Gateway ->

Call Routing -> New

e.g.

Administrative Status VoIP -> Media Gateway ->

Call Routing -> New

Type VoIP -> Media Gateway ->

Call Routing -> New

Calling Line VoIP -> Media Gateway ->

Call Routing -> New

Called Address VoIP -> Media Gateway ->

Call Routing -> New

e.g.

Priority VoIP -> Media Gateway ->

Call Routing -> New-> Add

Administrative Status VoIP -> Media Gateway ->

Call Routing -> New-> Add
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Field Menu Value

Outbound Line VoIP -> Media Gateway ->

Call Routing -> New-> Add

e.g.

Priority VoIP -> Media Gateway ->

Call Routing -> New-> Add

Administrative Status VoIP -> Media Gateway ->

Call Routing -> New-> Add

Outbound Line VoIP -> Media Gateway ->

Call Routing -> New-> Add

e.g.

Application Level Gateway

Field Menu Value

Description VoIP -> Application Level

Gateway -> <SIP UDP

5060>

e.g.

Administrative Status VoIP -> Application Level

Gateway -> <SIP UDP

5060>

Protocol VoIP -> Application Level

Gateway -> <SIP UDP

5060>

Destination Port VoIP -> Application Level

Gateway -> <SIP UDP

5060>

Session Timeout VoIP -> Application Level

Gateway -> <SIP UDP

5060>

Low Latency Transmission VoIP -> Application Level

Gateway -> <SIP UDP

5060>

Real Time Jitter Control

Field Menu Value

Interface WAN -> Real Time Jitter

Control -> Controlled Inter-

faces -> New

e.g.

Control Mode WAN -> Real Time Jitter

Control -> Controlled Inter-

faces -> New
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Field Menu Value

Maximum Upload Speed WAN -> Real Time Jitter

Control -> Controlled Inter-

faces -> New

e.g. kbit/s
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Chapter 5 Media Gateway - Connecting an

ISDN PBX to a sipgate VoIP account

This chapter describes how to configure a bintec media gateway to connect an existing

ISDN PBX to a sipgate VoIP account. By using a different trunk prefix outgoing connections

can be sent over the existing ISDN connection or via VoIP/sipgate. The extensions of the

existing ISDN line are used as outgoing lines for both connections. Incoming connections

are always accepted over ISDN.

Fig. 64: Example scenario

Requirements

The following are required for the configuration:

• The ISDN PBX is configured for operation on an ISDN point-to-multipoint connection. In

this example the following subscriber numbers are used: (0911)7660069-0 to

(0911)7660069-9

• The bintec media gateway is connected to the internet.

• An account has been set up with VoIP provider sipgate

• A bintec media gateway (e.g. R1200, R3000, R4100) with at least two ISDN BRI inter-

faces is required.

• The optional DSP module and any ISDN BRI licences that are required must be installed

Configuration in this scenario is carried out using the GUI (Graphical User Interface).

5.1 Configuration
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5.1.1 Configuring the sender number for the sipgate VoIP ac-

count

The settings of the sipgate account must be changed so that the correct subscriber number

can be determined for outgoing calls. The telephony settings must be changed as follows:

Fig. 65: Settings

5.1.2 Configuring the ISDN interfaces

The external ISDN 50 port on the PBX (point-to-multipoint connection) is connected to a

BRI port on the media gateway. The ISDN mode for this BRI port must be changed to

. To do this, the housing on the media gateway must be opened. The link plugs for the

ISDN-0 and ISDN-1 interfaces can be found on all devices on the main PCB behind the

ISDN terminal block.

For further information on setting the ISDN interfaces see Release Notes 7.5.1 (Chapter:

2.2 Variable switching for ISDN S0 interfaces).

Next, the ISDN configuration typecan be set on

.

(1) Go to Physical Interfaces -> ISDN Ports -> ISDN Configuration -> <bri2-0 (NT)

5 Media Gateway - Connecting an ISDN PBX to a sipgate

VoIP account

bintec elmeg GmbH

96 Workshops (Excerpt)



Fig. 66: Physical Interfaces -> ISDN Ports -> ISDN Configuration -> <bri2-0 (NT)

Relevant fields in the ISDN Configuration menu

Field Meaning

Port Name Shows the name of the ISDN port.

Port Usage
Select the protocol that you want to use for the ISDN port.

Select .

ISDN Configuration

Type

Here, select the ISDN access configuration

.

An additional ISDN port on the media gateway is connected with the NTBA for the external

ISDN line. The ISDN ports of the media gateway are already enabled in ISDN TE mode in

the ex works state and the ISDN switch type is recognised automatically when starting the

media gateway. As a result, no changes have to be made for this ISDN port.

(1) Go to Physical Interfaces -> ISDN Ports -> ISDN Configuration -> <bri2-1 (TE)

Fig. 67: Physical Interfaces -> ISDN Ports -> ISDN Configuration -> <bri2-1 (TE)

Relevant fields in the ISDN Configuration menu
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Field Meaning

Port Name Shows the name of the ISDN port.

Autoconfiguration on

Bootup

Here, select whether the ISDN switch type should be automatic-

ally recognised.

Result of Autoconfigura-

tion

The status of the ISDN autoconfiguration is displayed here.

Automatic D-channel recognition runs until a setting is found.

This field cannot be edited.

Port Usage
If the ISDN protocol is not automatically recognised, you must

select the port here manually. For this, you must first disable

Automatic Configuration at Start.

Select .

ISDN Configuration

Type

Here, select the ISDN access configuration

.

5.1.3 Configuring the sipgate VoIP account

The login data for registering the SIP accounts with provider sipgate are entered in the SIP

Accounts menu.

Additional settings are required in the Trunk Settings submenu to configure a SIP trunking

account. With outgoing calls sipgate allows a modified calling party number (caller number)

to be transmitted. With outgoing calls sent via the sipgate account, the calling party number

of the previously used ISDN point-to-multipoint connection is indicated. With the setting

your own subscriber number is indicated in the SIP header field of the SIP

INVITE message.

To create the account, add a new entry and configure the account as indicated below.

(1) Go to VoIP -> Media Gateway -> SIP Accounts -> New.
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Fig. 68: VoIP -> Media Gateway -> SIP Accounts -> New

Relevant fields in the SIP Accounts menu

Field Meaning

Description Here, assign a name to the account. Maximum number of char-

acters: 40.

Administrative Status Enable the administrative status of the account.

Trunk Mode Select the trunk mode to be used. If you select , the me-

dia gateway is run as a SIP client.

Registrar Enter the IP address of the remote SIP terminal (client or serv-

er) here. Maximum number of characters: 40.

Protocol Select the protocol to be used for the connection to the server

or proxy.

Port Number of the TCP or UDP port to be used for the connection
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Field Meaning

to the server or proxy.

User Name Here, enter the username for authentication if your VoIP pro-

vider has assigned one to you.

Authentication ID Enter a name that is to be used for authentication. If you do not

enter a name, the name in the User Name field is used.

Password The VoIP provider gives you a PIN or password for authentica-

tion. You must enter this value here. Maximum number of char-

acters: 40.

Registration Enables or disables the SIP REGISTER registration mechan-

ism.

Expire Time Shows the time in seconds after which the current registration

becomes invalid and a new registration request is therefore

sent.

SIP Header Field(s) for

Caller Address This option defines where and how the DDI sender (caller) ad-

dress is sent for outgoing calls.

Select . the sender address is placed in the

Display field of the SIP header.

In the Advanced Settings menu, perform the settings for the SIP protocol and other spe-

cific settings. In the Codec Settings submenu you can define which codecs are used for

the chosen account. The settings can be applied without changes.

Some fields are optional and only have to be set if required for the corresponding account.

Relevant fields in the menu Advanced Settings

Field Meaning

Codec Proposal Se-

quence Determine the order in which the codecs are offered for use by

the media gateway. If the first codec cannot be applied, an at-

tempt is made to use the second codec, and so on. Set Codec

Proposal Sequence to . The codec in the first posi-

tion will be used.

You can sort the codecs according to quality or bandwidth.

Sort Order Select the codecs to be proposed for the connection. The co-

decs chosen here are proposed in a certain order, depending

on the setting in the Codec Proposal Sequence field.

Echo cancellation Enable or disable echo cancellation. If is selected,

echo feedback is suppressed.
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Field Meaning

Comfort Noise Genera-

tion Specify whether Comfort Noise Generation should be used. The

slight comfort noise generation prevents subscribers from think-

ing that the connection is lost during pauses.

Packet Size The transmission time of an RTP data packet in milliseconds.

Possible values: 10 ... 60.

If registration with the VoIP provider is successful, the status in the provider menu shows

. The status of the VoIP connection is changed by pressing the button or button in

the Action column.

(1) Go to VoIP -> Media Gateway -> SIP Accounts.

Fig. 69: VoIP -> Media Gateway -> SIP Accounts

5.1.4 Configuring the internal extensions

In this example the internal ISDN port to connect to the ISDN PBX is operated as an ISDN

point-to-multipoint connection. It is therefore necessary to store the external MSN numbers

for the PBX. If more than one ISDN port is used in ISDN NT Mode (point-to-multipoint) on

the media gateway, the respective ISDN port can be selected.

(1) Go to VoIP -> Media Gateway -> Extensions -> New.
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Fig. 70: VoIP -> Media Gateway -> Subscriber -> New

Relevant fields in the Extensions menu

Field Meaning

Extension / User Name Enter the subscriber number here. Maximum number of charac-

ters: 40.

Interface Type
Terminal type, an internal PBX is used for the call.

The setting can only be selected if ISDN interfaces with

the ISDN Configuration Type =

is set.

Select ISDN interface Select an interface. The ISDN interface you can select depends

on the device used.

In our example, the 10 external MSN subscriber numbers for the PBX are connected to the

ISDN port on the media gateway. The complete configuration looks like this:

(1) Go to VoIP -> Media Gateway -> Extension.

Fig. 71: VoIP -> Media Gateway -> Extension

5 Media Gateway - Connecting an ISDN PBX to a sipgate

VoIP account

bintec elmeg GmbH

102 Workshops (Excerpt)



5.1.5 Extension assignment - Call routing - Call translation

An MSN subscriber number of the PBX should be stored as the Default Extension in the

PBX Configuration menu. Here you can nominate an extension to receive calls that can-

not be routed because there is no valid routing entry for them.

(1) Go to VoIP -> Media Gateway -> Options.

Fig. 72: VoIP -> Media Gateway -> Options

Relevant fields in the Options menu

Field Meaning

Session Border Control-

ler Mode Determines the behaviour of the media gateway in combination

with a session border controller. Select

: call routing is handles exclusively by the media gateway in

accordance with the configured call routing and the local exten-

sions. For calls that are to be routed via a particular provider

(account), you must configure a corresponding call routing

entry. Internal calls (from internal extension to internal exten-

sion) that are only to be routed internally do not require an addi-

tional call routing entry.

Media Stream Termina-

tion Determines how RTP sessions are controlled by the system.

Select

: RTP sessions are terminated on the media gateway, i.e. all

RTP streams are controlled by the media gateway and routed

via the media gateway. The participating terminal devices (e.g.

SIP telephones) are not connected directly with one another.

Note that, for VoIP to VoIP connections, there is no code trans-
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Field Meaning

lation for different VoIP terminal codecs. This is why the codecs

from media gateway and VoIP terminals must match; the RTP

sessions are not terminated on the media gateway, i.e. all RTP

streams are routed from the media gateway without termination.

The RTP data packets can be routed in complex networks and

thus also via other gateways.

Default Drop Extension Here you can nominate an extension to receive calls that cannot

be routed because there is no valid routing entry for them.

Dialling break
Maximum delay time before the system assumes the telephone

number entered is complete and starts the SIP dialling process

(sends the SIP INVITE message).

This timeout is reset each time that a button is pressed. If you

terminate the number entered with #, dialling is immediate.

Call Routing

The Call Routing menu determines whether outgoing connections are routed over the

ISDN line or over the sipgate VoIP account. Here you can decide over which line the outgo-

ing call is initiated for each called or calling party number (with a special number as a trunk

prefix).

Our example shows the call routing entry through which all outgoing calls with an interna-

tional destination number (e.g. 0043, 0033) are initiated over the sipgate VoIP account. The

Calling Line option indicates the ISDN port of the media gateway that is connected to the

ISDN PBX.

(1) Go to VoIP -> Media Gateway -> Call Routing -> New.
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Fig. 73: VoIP -> Media Gateway -> Call Routing -> New

Relevant fields in the Call Routing menu

Field Meaning

Description Here, enter the name of the call routing entry.

Administrative Status The entry is used with .

Type Select for calls that are to be routed as outgoing, ex-

ternal calls.

Calling Line Here you can restrict the routing entry to the line on which the

call comes in.

Calling Address Here you can restrict the routing entry to a particular caller. To

do this, you must specify the subscriber number exactly (no

wildcards).

Called Address Here, you can enter an address (call number) that is compared

with the dialled address. You can use wildcards here. For ex-

ample means that at the end of a character string an arbit-

rary number of any characters can follow.

You can now select the ISDN line or SIP provider account to be used for this call entry (for

outgoing connections).

Use Add to create entries.

Relevant fields in the Routing Rule menu
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Field Meaning

Priority Determines the order of the filter rules, starting with in in-

creasing numerical order.

Administrative Status The entry is used with .

Outbound Line Defines the PSTN line (PRI, BRI, FXO) or the SIP account used

for an outgoing call.

An additional call routing entry is required for outgoing connections (without international

prefix).

The Calling Line option indicates the ISDN port of the media gateway that is connected to

the ISDN PBX.

(1) Go to VoIP -> Media Gateway -> Call Routing -> New.

Fig. 74: VoIP -> Media Gateway -> Call Routing -> New

If you select Add the external connection (ISDN line or SIP provider account) used for this

entry is selected. In our example, the ISDN port has been connected with the ex-

ternal ISDN point-to-multipoint exchange connection.

The complete configuration looks like this:

(1) Go to VoIP -> Media Gateway -> Call Routing .
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Fig. 75: VoIP -> Media Gateway -> Call Routing

Call Translation

Call translation is necessary to ensure that the calling party number (outgoing line) is trans-

mitted correctly for outgoing calls initiated over the sipgate VoIP account. This call transla-

tion is configured in the Call Translation menu. In the following configuration the MSN

subscriber numbers for the ISDN PBX are preceded with the prefix for outgoing

calls. If, for example, a call is initiated over sipgate with the calling party number 76600695,

the call is signalled with the subscriber number 4991176600695.

(1) Go to VoIP -> Media Gateway -> Call Translation -> New.

Fig. 76: VoIP -> Media Gateway -> Call Translation -> New

Relevant fields in the Call Translation menu

Field Meaning

Description Give the number translation a name.

Direction
Here you enter the direction to which the entry is to apply.

Select for outgoing calls.

Associated Line Determines the line or SIP account via which the calls are to be

routed.
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Field Meaning

Local Address
Here you enter the internal number (e.g. extension or PBX num-

ber).

For outgoing calls, the signalled Calling Party Number

(corresponds in the menu to the Local Address field) is trans-

lated to the External Address.

Numerical and alphanumerical characters are permissible.

? is a placeholder for an arbitrary digit.

Note Local Address and External Address must contain the

same number of wildcards.

External Address Enter the external number here. For outgoing calls, the sig-

nalled called party number (corresponding in the menu to the

Local Address field) is translated to the External Address.

5.2 Overview of configuration steps

ISDN interface configuration

Field Menu Value

Port Usage Physical Interfaces -> ISDN

Ports -> ISDN Configura-

tion -> <bri2-0 (NT)

ISDN Configuration Type Physical Interfaces -> ISDN

Ports -> ISDN Configura-

tion -> <bri2-0 (NT)

Configuring the second ISDN interface

Field Menu Value

Autoconfiguration on Bootup Physical Interfaces -> ISDN

Ports -> ISDN Configura-

tion -> <bri2-1 (TE)

Result of Autoconfiguration Physical Interfaces -> ISDN

Ports -> ISDN Configura-

tion -> <bri2-1 (TE)

SIP Account Configuration
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Field Menu Value

Description VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

Administrative Status VoIP -> Media Gateway ->

SIP Accounts -> New

Trunk Mode VoIP -> Media Gateway ->

SIP Accounts -> New

Registrar VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

Protocol VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

Port VoIP -> Media Gateway ->

SIP Accounts -> New

User Name VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

Password VoIP -> Media Gateway ->

SIP Accounts -> New

e.g.

Registration VoIP -> Media Gateway ->

SIP Accounts -> New

Expire Time VoIP -> Media Gateway ->

SIP Accounts -> New

Sec

SIP Header Field(s) for

Caller Address

VoIP -> Media Gateway ->

SIP Accounts -> New

Codec Proposal Sequence VoIP -> Media Gateway ->

SIP Accounts -> New-> Ad-

vanced Settings

Echo cancellation VoIP -> Media Gateway ->

SIP Accounts -> New-> Ad-

vanced Settings

Comfort Noise Generation

(CNG)

VoIP -> Media Gateway ->

SIP Accounts -> New-> Ad-

vanced Settings

Aktiviert

Packet Size VoIP -> Media Gateway ->

SIP Accounts -> New-> Ad-

vanced Settings

ms

Configuring the internal extension

Field Menu Value

Extension / User Name VoIP -> Media Gateway -> e.g.
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Field Menu Value

Subscriber -> New

Interface Type VoIP -> Media Gateway ->

Subscriber -> New

Select ISDN interface VoIP -> Media Gateway ->

Subscriber -> New

e.g.

Call Assignment

Field Menu Value

Session Border Controller

Mode

VoIP -> Media Gateway ->

Options

Media Stream Termination VoIP -> Media Gateway ->

Options

Default Drop Extension VoIP -> Media Gateway ->

Options

e.g.

Dialling break VoIP -> Media Gateway ->

Options

e.g. seconds

Call Routing

Field Menu Value

Description VoIP -> Media Gateway ->

Call Routing -> New

e.g.

Administrative Status VoIP -> Media Gateway ->

Call Routing -> New

Type VoIP -> Media Gateway ->

Call Routing -> New

Calling Line VoIP -> Media Gateway ->

Call Routing -> New

Called Address VoIP -> Media Gateway ->

Call Routing -> New

e.g.

Priority VoIP -> Media Gateway ->

Call Routing -> New-> Add

Administrative Status VoIP -> Media Gateway ->

Call Routing -> New-> Add

Outbound Line VoIP -> Media Gateway ->

Call Routing -> New-> Add

e.g.

Description VoIP -> Media Gateway ->

Call Routing -> New

e.g.
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Field Menu Value

Administrative Status VoIP -> Media Gateway ->

Call Routing -> New

Type VoIP -> Media Gateway ->

Call Routing -> New

Calling Line VoIP -> Media Gateway ->

Call Routing -> New

Called Address VoIP -> Media Gateway ->

Call Routing -> New

e.g.

Priority VoIP -> Media Gateway ->

Call Routing -> New-> Add

Administrative Status VoIP -> Media Gateway ->

Call Routing -> New-> Add

Outbound Line VoIP -> Media Gateway ->

Call Routing -> New-> Add

e.g.

Call Translation

Field Menu Value

Description VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Direction VoIP -> Media Gateway ->

Call Translation -> New

Associated Line VoIP -> Media Gateway ->

Call Translation -> New

e.g.

Local Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.

External Address VoIP -> Media Gateway ->

Call Translation -> New

e.g.
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Chapter 6 Media Gateway - Configuration for

connection of a SwyxWare IP-PBX to an ISDN

point-to-multipoint

6.1 Introduction

This chapter describes configuration of the bintec R4100 as a media gateway for connec-

tion of a SwyxWare IP PBX to an ISDN point-to-multipoint.

The ISDN point-to-multipoint connection was wired with the block of numbers (MSN)

6898924 to 6898927. The SwyxWare IP PBX is connected to the media gateway via a SIP

gateway trunk. All incoming calls are delivered to the SwyxWare IP PBX. Outgoing calls

are routed into the ISDN network.

Fig. 77: Example scenario

Requirements

The following are required for the configuration:

• A bintec R4100 with 7.8.4 system software

• A DSP module (4-way) must be installed.

• The ISDN port must be connected to the ISDN point-to-multipoint.

• The SwyxWare IP-PBX must already be preconfigured (user and terminal configuration ,

etc.).

Configuration of the bintec R4100 is performed using the GUI (Graphical User Interface).

6 Media Gateway - Configuration for connection of a Swyx-

Ware IP-PBX to an ISDN point-to-multipoint

bintec elmeg GmbH

112 Workshops (Excerpt)



6.2 Configuration

6.2.1 Configuration of a trunk group in the SwyxWare adminis-

trator

To create a new SIP gateway trunk in the SwyxWareadministrator, a new trunk group must

first be configured. Trunk groups consist of one or more trunks possessing similar charac-

teristics.

The assistant to create a new trunk group is launched in the SwyxWareadministrator. For

this, go to the following menu:

(1) Go to Trunk Groups -> Add Trunk Group... .

Fig. 78: Create new trunk group

The assistant to add a trunk groupopens. Follow the assistant's instructions.
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Fig. 79: Assistant for adding a trunk group

Click Next.

First, a name must be assigned to the trunk group.

Fig. 80: Name of trunk group

(1) Under Name of Trunk Group enter , for example.

In the next step, the type of trunk group is defined.
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Fig. 81: Type of trunk group

(1) To connect a bintec media gateway, select in Type of Trunk Group .

(2) In Profil, select .

In our example, all outgoing calls are routed over the bintec media gateway.

Fig. 82: Definition of forwarding

(1) In Use trunks from this group..., select .

In this example, incoming calls are not subject to call restrictions.
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Fig. 83: Call authorisation

(1) In Call Authorisation, select .

As the last step of this assistant, the trunk group is assigned a locality.

Fig. 84: Locality profile

(1) In Locality, select one of the localities configured in theSwyxWareadministrator.
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Fig. 85: Close assistant

Configuration of the trunk group is thus complete. Click Finish.

6.2.2 Configuration of a SIP trunk in the SwyxWare adminis-

trator

After creation of a trunk group, configuration of a SIP trunk for connection of the bintec me-

dia gateway can begin.

The assistant to create a trunk is launched in the SwyxWareadministrator. For this, click on

the associated trunk group:

(1) Go to Trunk Groups -> Demo Trunk Group... -> Add Trunk... .
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Fig. 86: Add trunk

The assistant to add a trunkopens. Follow the assistant's instructions.

Fig. 87: Assistant for adding a trunk

Click Next.

At the beginning of the assistant, a name and description must be assigned to the trunk for

connection to the bintec media gateway.
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Fig. 88: Trunk name

(1) Under Trunk name enter , for example.

(2) For example, under Description enter .

At the next step of the assistant, the SIP user and SIP authentication are entered. These

data are required for registration of the bintec media gateway.

Fig. 89: SIP account

(1) In User ID enter an elective value, e. g. .

(2) Set Authentication Method to .

(3) In User Name, enter an elective value, e. g. .

(4) UnderPassword enter your password.
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In our example, the media gateway is operated on an ISDN point-to-multipoint connection

with a continuous block of numbers (MSN: 6898924-6898927). This block of numbers is

assigned to the trunk group.

Fig. 90: Subscriber numbers

(1) With continuous numbers, under First Number enter the first number of the block of

numbers (here, e.g., ).

(2) Under Last Number, enter the last number of the block of numbers (here, e.g.,

).

The codec selection is taken over unchanged.

Fig. 91: Codecs
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In our example, the bintec media gateway is operated on an ISDN point-to-multipoint con-

nection. For this reason, the number of simultaneous calls is limited to .

Fig. 92: Number of channels

As the last step of the assistant, the trunk to the bintec media gateway is assigned to the

SwyxWare server.

Fig. 93: Computer name

(1) Under Computer, enter the computer name of the SwyxWare server.

(2) This concludes trunk configuration. Click Finish.

bintec elmeg GmbH 6 Media Gateway - Configuration for connection of a Swyx-

Ware IP-PBX to an ISDN point-to-multipoint

Workshops (Excerpt) 121



6.2.3 Configuration of the bintec media gateway

ISDN interface configuration

The ISDN port of the media gateway is connected to the NTBA of the point-

to-multipoint. Configuration of the ISDN interface is already wired in ISDN TE mode ex-

works, and the ISDN switch type is automatically recognised at media gateway startup.

Do not perform any modifications for this port in menu Physical Interfaces -> ISDN Ports -

> ISDN Configuration -> <bri2-0 (TE) .

Fig. 94: Physical Interfaces -> ISDN Ports -> ISDN Configuration -> <bri2-0 (TE)

SIP Account Configuration

A SIP account must be created at gateway configuration for connection of the bintec media

gateway.

To save the login data for registering the media gateway with the SwyxWare IP PBX, go to

the following menu:

(1) Go to VoIP -> Media Gateway -> SIP Accounts -> New.
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Fig. 95: VoIP -> Media Gateway -> SIP Accounts -> New

Relevant fields in the SIP Accounts menu

Field Description

Description Here, assign a name to the account. Maximum number of char-

acters: 40.

Administrative Status Enable the administrative status of the account.

Trunk Mode Select the trunk mode to be used. If you select , the

gateway trunk is used.

Registrar Here, enter the IP address of the SwyxWareserver. Maximum

number of characters: 40.

Protocol Select the protocol to be used for the connection to the server

or proxy.

Port Number of the TCP or UDP port to be used for the connection

to the server or proxy.

User Name Here, enter the username for authentication if your VoIP pro-

vider has assigned one to you.

Authentication ID Enter a name that is to be used for authentication. If you do not

enter a name, the name in the User Name field is used.

Password The VoIP provider gives you a PIN or password for authentica-

tion. You must enter this value here. Maximum number of char-
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Field Description

acters: 40.

Registration Enables or disables the SIP REGISTER registration mechan-

ism.

Expire Time Shows the time in seconds after which the current registration

becomes invalid and a new registration request is therefore

sent. Here, the SIP expire time is matched to the SwyxWare IP

PBX. seconds are used as the default value.

SIP Header Field(s) for

Caller Address

With a SIP trunk to the SwyxWare IP PBX, the outgoing num-

ber is indicated via the SIP header field

(according to RFC 3325) in the SIP INVITE message.

Call Routing

In this example, all incoming calls over the ISDN line are routed to the SwyxWare IP PBX.

All outgoing calls (SwyxWare IP PBX -> ISDN) are routed by the media gateway to the

ISDN line. Two routing entries are necessary for this. Shown below is the configuration of

the call routing entry for outgoing connections.

(1) Go to VoIP -> Media Gateway -> Call Routing -> New.

Fig. 96: VoIP -> Media Gateway -> Call Routing -> New

Relevant fields in the Call Routing menu
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Field Description

Description Here, enter the name of the call routing entry.

Administrative Status The entry is used with .

Type Select for calls that are to be routed as outgoing, ex-

ternal calls.

Calling Line Here you can restrict the routing entry to the line on which the

call comes in.

The selection depends on the interfaces available and on the

SIP accounts that have been created.

If you select , the routing entry is restricted to the se-

lected SIP account.

Calling Address Here you can restrict the routing entry to a particular caller. To

do this, you must specify the subscriber number exactly (no

wildcards).

Called Address Here, you can enter an address (call number) that is compared

with the dialled address. You can use wildcards here. For ex-

ample, means that at the end of a character string any num-

ber of additional characters can follow.

If the configured address agrees with the signalled address, the

routing entry is used.

You can now create a list with rules that are assigned to the currently selected routing

entry, and that serve to manipulate the signalled destination number. You can also delete

routing entries.

Use Add to create entries.

Relevant fields in the Routing Rule menu

Field Description

Priority Determines the order of the filter rules, starting with in in-

creasing numerical order.

Administrative Status The entry is used with .

Outbound Line Defines the PSTN line (PRI, BRI, FXO) or the SIP account used

for an outgoing call.

A call routing entry for incoming calls must then be configured.

(1) Go to VoIP -> Media Gateway -> Call Routing -> New.
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Fig. 97: VoIP -> Media Gateway -> Call Routing -> New

Relevant fields in the Call Routing menu

Field Description

Description Here, enter the name of the call routing entry.

Administrative Status The entry is used with .

Type Select for calls that are routed to a PBX behind the me-

dia gateway.

Calling Line Here you can restrict the routing entry to the line on which the

call comes in.

The selection depends on the interfaces available and on the

SIP accounts that have been created.

If you select , the routing entry is restricted to the se-

lected SIP account.

Calling Address Here you can restrict the routing entry to a particular caller. To

do this, you must specify the subscriber number exactly (no

wildcards).

Called Address Here, you can enter an address (call number) that is compared

with the dialled address. You can use wildcards here. For ex-

ample, means that at the end of a character string any num-

ber of additional characters can follow.

If the configured address agrees with the signalled address, the

routing entry is used.

After creation of both entries, these are displayed in the Routing menu.
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(1) Go to VoIP -> Media Gateway -> Call Routing .

Fig. 98: VoIP -> Media Gateway -> Call Routing

6.3 Overview of configuration steps

Add trunk group

Field Menu Value

SwyxWare Adminis-

tration

SwyxWare -> Swyx Server -> Trunk

Groups -> Add Trunk Group...

e. g.

Assistant

Field Menu Value

Assistant Assistant for adding a trunk group Next

Name of trunk group Assistant for adding a trunk group e. g.

Type of trunk group Assistant for adding a trunk group e.g.

Profile Assistant for adding a trunk group e. g.

Definition of forward-

ing

Assistant for adding a trunk group

Call authorisation Assistant for adding a trunk group

Locality profile Assistant for adding a trunk group e. g.

Add trunk

Field Menu Value

SwyxWare Adminis-

tration

SwyxWare -> Swyx Server -> Trunk

Groups -> Demo Trunk Group -> Add

Trunk...

e. g.
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Assistant

Field Menu Value

Assistant Assistant for adding a trunk Next

Trunk name Assistant for adding a trunk -> Trunk

Name

e. g.

Description Assistant for adding a trunk -> Trunk

Name

e.g.

User ID Assistant for adding a trunk ->SIP Ac-

count

e. g.

Authentication meth-

od

Assistant for adding a trunk ->SIP Ac-

count

e.g.

User Name Assistant for adding a trunk ->SIP Ac-

count

e. g.

Password Assistant for adding a trunk ->SIP Ac-

count

Password

First call number Assistant for adding a trunk ->Call

number

e.g.

Last call number Assistant for adding a trunk ->Call

number

e.g.

Number of channels Assistant for adding a trunk

Computer name Assistant for adding a trunk e. g.

ISDN interface configuration

Field Menu Value

Autoconfiguration on

Bootup

Physical Interfaces -> ISDN Ports ->

ISDN Configuration -> <bri2-0 (TE)

Result of Autoconfig-

uration

Physical Interfaces -> ISDN Ports ->

ISDN Configuration -> <bri2-0 (TE)

Configuration of SIP accounts

Field Menu Value

Description VoIP -> Media Gateway -> SIP Ac-

counts -> New

e. g.

Administrative

Status

VoIP -> Media Gateway -> SIP Ac-

counts -> New
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Field Menu Value

Trunk Mode VoIP -> Media Gateway -> SIP Ac-

counts -> New

gw-trunk

Registrar VoIP -> Media Gateway -> SIP Ac-

counts -> New

e. g.

Protocol VoIP -> Media Gateway -> SIP Ac-

counts -> New

e.g.

Port VoIP -> Media Gateway -> SIP Ac-

counts -> New

User Name VoIP -> Media Gateway -> SIP Ac-

counts -> New

e. g.

Password VoIP -> Media Gateway -> SIP Ac-

counts -> New

e.g.

Registration VoIP -> Media Gateway -> SIP Ac-

counts -> New

Expire Time VoIP -> Media Gateway -> SIP Ac-

counts -> New

Sec

SIP Header Field(s)

for Caller Address

VoIP -> Media Gateway -> SIP Ac-

counts -> New

e.g.

Call routing for outgoing calls

Field Menu Value

Description VoIP -> Media Gateway -> Call Routing

-> New

e. g.

Administrative

Status

VoIP -> Media Gateway -> Call Routing

-> New

Type VoIP -> Media Gateway -> Call Routing

-> New

Calling Line VoIP -> Media Gateway -> Call Routing

-> New

e. g.

Called Address VoIP -> Media Gateway -> Call Routing

-> New

e.g.

Priority VoIP -> Media Gateway -> Call Routing

-> New-> Add

Administrative

Status

VoIP -> Media Gateway -> Call Routing

-> New-> Add

Outbound Line VoIP -> Media Gateway -> Call Routing

-> New-> Add

e.g.
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Call routing for incoming calls

Field Menu Value

Description VoIP -> Media Gateway -> Call Routing

-> New

e. g.

Administrative

Status

VoIP -> Media Gateway -> Call Routing

-> New

Type VoIP -> Media Gateway -> Call Routing

-> New

Calling Line VoIP -> Media Gateway -> Call Routing

-> New

e.g.

Called Address VoIP -> Media Gateway -> Call Routing

-> New

e.g.

Trunk Line VoIP -> Media Gateway -> Call Routing

-> New

e. g.
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Chapter 7 Media Gateway - Connection of a

virtualised serVonic IXI-UMS server to a bintec

R1200

7.1 Introduction

This chapter describes connection of a serVonic IXI-UMSsolution operated in a VMware

environment to the ISDN network.

For this, the serVonic IXI-UMS kernel uses the remote CAPI interface of the bintec R1200

router. For provision of all required CAPI protocols (e.g., T.30 modem for FAX G3), the

bintec R1200/R3000/R4100 must be equipped with the optional VoIP DSP module.

In our example, a ISDN point-to-multipoint is used for the ISDN connection.

The GUI (Graphical User Interface) is used here for configuration of the bintec R1200.

Fig. 99: Example scenario

Requirements

The following are required for the configuration:

• A bintec R1200 with 7.8.4 system software.

• A DSP module (4-way) must be installed.

• Basic installation of the IXI-UMS kernel is assumed, along with an existing VMware envir-

onment.

• During installation, the router must already be connected to the ISDN point-to-multipoint.

7.2 Configuration
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7.2.1 Configuration of the bintec R1200 as a remote CAPI serv-

er

Installation of the DSP module

Detailed information on installing the DSP module can be found in the release notes for the

system software version 7.5.1., chapter: 2.1 DSP Module - Installation and function testing

(http://www.bintec-elmeg.com /

portal/downloadcenter/dateien/r1200/r7501p01/relnote_751_de.pdf).

Following successful installation of the DSP module, the module type is displayed on the

GUI status page.

In our example, .

(1) Go to System Administration -> Status.
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Fig. 100: System Administration ->Status

ISDN interface configuration

The router's ISDN port must already be connected with the ISDN point-to-multipoint during

the configuration. At startup of the bintec R1200 the router performs an ISDN auto-

recognition and displays the result.

In the Physical Interfaces -> ISDN Ports -> ISDN Configuration menu, a list of all ISDN

ports and their configurations is shown.

Here, the ISDN point-to-multipoint connection was successfully recognised.
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Fig. 101: Physical Interfaces -> ISDN Ports-> ISDN Configuration

Ex works (or without MSN configuration), the router accepts all incoming ISDN connec-

tions, thus permitting remote configuration via ISDN login. As the router in our example

routes all connections to the serVonic IXI-UMSsolution, a "dummy call number" must be

configured. As soon as an entry exists, the incoming calls not assigned to any entry are for-

warded to the CAPI service.

(1) Go to Physical Interfaces -> ISDN Ports -> MSN Configuration -> New.

Fig. 102: Physical Interfaces -> ISDN Ports -> MSN Configuration -> New

Relevant fields in the MSN Configuration menu

Field Description

ISDN Port Select the ISDN port for which the MSN is to be configured.

Service Select the service to which a call is to be assigned on the MSN.

MSN Enter any number here (dummy call number).

MSN Recognition
Select the mode your device is to use for the number comparis-

on of MSN with the called party number of the incoming call.

Possible values:

• (default value)

• : If your device is connected to a

point-to-point connection.

Service attribute Select the type of incoming call.
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Remote CAPI server configuration

The remote CAPI server of the bintec R1200 is already enabled ex-works.

(1) Go to Local Services -> CAPI Server->Options.

Fig. 103: Local Services ->CAPI Server ->Options

Relevant fields in the Options menu

Field Description

Enable server
The function is activated by selecting .

The function is enabled by default.

CAPI Server TCP Port
The field can only be edited if Enable Server is enabled.

Enter the TCP port number for remote CAPI connections.

The default value is .

For security reasons, access to the remote CAPI interface should be protected with a user

name and password.

Note

Ex works, a user with the user name and no password is always entered for

the CAPI subsystem. All calls to the CAPI are offered to all CAPI applications in the

LAN. Use the Settings menu to distribute incoming calls for the CAPI subsystem to

defined users with password. You should then delete the user without pass-

word.

bintec elmeg GmbH 7 Media Gateway - Connection of a virtualised serVonic IXI-

UMS server to a bintec R1200

Workshops (Excerpt) 135



(1) Go to Local Services -> CAPI Server->User->New.

Fig. 104: Local Services ->CAPI Server ->User-> New.

Relevant fields in the User menu

Field Description

User Name Enter the user name for which access to the CAPI service is to

be allowed.

Password Enter the password which the user shall use for identification to

gain access to the CAPI service.

Access
Select whether access to the CAPI service is to be permitted or

denied for the user.

The function is activated by selecting .

7.2.2 Configuration of remote CAPI client software

The remote CAPI client software is a component of the BRICKware software package. The

latter is located on the provided companion CD, or can be accessed in the download area

at www.bintec-elmeg.com . The remote CAPI client software is installed in the BRICKware

program group.
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Fig. 105: Remote Clients Configuration

(1) To log in the remote CAPI client, the Device IP address or host name of the bintec

R1200must be saved.

(2) Under User enter , for example.

(3) Enter the password.

(4) Apply the configuration with Use these values.

(5) As confirmation, a corresponding message appears in the info area of the remote

CAPI client software.

Detailed in information about the configured CAPI servers and their CAPI controllers is

provided under Remote Multi CAPI Client Configuration .

Following login of the remote CAPI client software bintec router, which functions as CAPI

server, one CAPI controller is displayed per ISDN interface.

Fig. 106: Remote Multi CAPI Client Configuration
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7.2.3 IXI-UMS kernel configuration for the remote CAPI inter-

face

With basic installation of the serVonic IXI-UMS kernel, the SerVonic->IXI-UMSprogram

group was created on your server. There, you will find the IXI-UMS Kernel Configuration

Microsoft Management Console. In this Management Console, the dialog for configuration

of the ISDN hardware is launched.

(1) Go to IXI-UMS Kernel Configuration -> Hardware -> Properties .

Fig. 107: IXI-UMS Kernel Configuration

With the Hardware Detection of the IXI-UMS kernel, the remote CAPI interface is recog-

nised as ISDN hardware.
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Fig. 108: Hardware

Under Add ISDN device, an ISDN controller with two B-channels is displayed. This dialog

also offers the option of limiting the number of usable CAPI controllers.

With Add, you can modify the properties of the respective CAPI controllers (e.g., number of

available B-channels).

Fig. 109: Add ISDN device

After confirmation, the IXI-UMS kernel services are restarted. Following this, two available

ISDN B-channels are displayed inIXI-UMS Kernel Monitor under Channels with Ready

status.
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Fig. 110: IXI-UMS Kernel Monitor

In IXI-Kernel Monitor a test fax can now be sent.

(1) Go to IXI-UMS Kernel Monitor -> Queue.

Fig. 111: Test IXI-UMS Kernel

Further configuration of the serVonic IXI-UMSsolution will not be discussed here. For con-

nections to various server systems, such as Microsoft Exchange Server, Lotus Domino,

etc., we refer you to our Technology Partner, serVonic.
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7.3 Overview of configuration steps

MSN Configuration

Field Menu Value

ISDN Port Physical Interfaces -> ISDN Ports ->

MSN Configuration -> New

Service Physical Interfaces -> ISDN Ports ->

MSN Configuration -> New

MSN Physical Interfaces -> ISDN Ports ->

MSN Configuration -> New

e.g.

MSN Recognition Physical Interfaces -> ISDN Ports ->

MSN Configuration -> New

Service attribute Physical Interfaces -> ISDN Ports ->

MSN Configuration -> New

Remote CAPI server configuration

Field Menu Value

Enable server Local Services ->CAPI Server ->Op-

tions

CAPI Server TCP

Port

Local Services ->CAPI Server ->Op-

tions

e.g.

User Name Local Services ->CAPI Server ->User->

New.

e.g. .

Password Local Services ->CAPI Server ->User->

New.

Access Local Services ->CAPI Server ->User->

New.

Configuration of remote CAPI client software

Field Menu Value

Device IP address or

host name

Remote Clients Configuration e.g.

User Remote Clients Configuration

Password Remote Clients Configuration
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Chapter 8 Media Gateway - Connection of a

virtualised serVonic Tobit David server to a

bintec R1200

8.1 Introduction

This chapter describes connection of a serVonic Tobit Davidserver operated in a VMware

environment to the ISDN network. For this, the David server uses the remote CAPI inter-

face of the bintec R1200 router. For provision of all required CAPI protocols (e.g., T.30

modem for FAX G3), the bintec R1200/R3000/R4100 must be equipped with the optional

VoIP DSP module.

In our example, a ISDN point-to-multipoint is used for the ISDN connection.

The GUI (Graphical User Interface) is used here for configuration of the bintec R1200.

Fig. 112: Example scenario

Requirements

The following are required for the configuration:

• A bintec R1200 with 7.8.4 system software.

• A DSP module (4-way) must be installed.

• Basic installation of the Tobit David server is assumed, along with an existing VMware

environment.

• During installation, the router must already be connected to the ISDN point-to-multipoint.
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8.2 Configuration

8.2.1 Configuration of the bintec R1200 as a remote CAPI serv-

er

Installation of the DSP module

Detailed information on installing the DSP module can be found in the release notes for the

system software version 7.5.1., chapter: 2.1 DSP Module - Installation and function testing

(http://www.bintec-elmeg.com /

portal/downloadcenter/dateien/r1200/r7501p01/relnote_751_de.pdf).

Following successful installation of the DSP module, the module type is displayed on the

GUI status page.

In our example, .

(1) Go to System Administration -> Status.
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Fig. 113: System Administration ->Status

ISDN interface configuration

The router's ISDN port must already be connected with the ISDN point-to-multipoint during

the configuration. At startup of the bintec R1200, the router performs an ISDN auto-

recognition and displays the result.

In the Physical Interfaces -> ISDN Ports -> ISDN Configuration menu, a list of all ISDN

ports and their configurations is shown.

Here, the ISDN point-to-multipoint connection was successfully recognised.
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Fig. 114: Physical Interfaces -> ISDN Ports-> ISDN Configuration

Ex works (or without MSN configuration), the router accepts all incoming ISDN connec-

tions, thus permitting remote configuration via ISDN login. As the router in our example

routes all connections to the serVonic Tobit David Server, a "dummy call-number" must be

configured. As soon as an entry exists, the incoming calls not assigned to any entry are for-

warded to the CAPI service.

(1) Go to Physical Interfaces -> ISDN Ports -> MSN Configuration -> New.

Fig. 115: Physical Interfaces -> ISDN Ports -> MSN Configuration -> New

Relevant fields in the MSN Configuration menu

Field Description

ISDN Port Select the ISDN port for which the MSN is to be configured.

Service Select the service to which a call is to be assigned on the MSN.

MSN Enter any number here (dummy call number).

MSN Recognition
Select the mode your device is to use for the number comparis-

on of MSN with the called party number of the incoming call.

Possible values:

• (default value)

• : If your device is connected to a

point-to-point connection.

Service attribute Select the type of incoming call.
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Remote CAPI server configuration

The remote CAPI server of the bintec R1200 is already enabled ex-works.

(1) Go to Local Services -> CAPI Server->Options.

Fig. 116: Local Services ->CAPI Server ->Options

Relevant fields in the Options menu

Field Description

Enable server
The function is activated by selecting .

The function is enabled by default.

CAPI Server TCP Port
The field can only be edited if Enable Server is enabled.

Enter the TCP port number for remote CAPI connections.

The default value is .

For security reasons, access to the remote CAPI interface should be protected with a user

name and password.

Note

Ex works, a user with the user name and no password is always entered for

the CAPI subsystem. All calls to the CAPI are offered to all CAPI applications in the

LAN. Use the Settings menu to distribute incoming calls for the CAPI subsystem to

defined users with password. You should then delete the user without pass-

word.
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(1) Go to Local Services -> CAPI Server->User->New.

Fig. 117: Local Services ->CAPI Server ->User-> New.

Relevant fields in the User menu

Field Description

User Name Enter the user name for which access to the CAPI service is to

be allowed.

Password Enter the password which the user shall use for identification to

gain access to the CAPI service.

Access
Select whether access to the CAPI service is to be permitted or

denied for the user.

The function is activated by selecting .

8.2.2 Configuration of remote CAPI client software

The remote CAPI client software is a component of the BRICKware software package. The

latter is located on the provided companion CD, or can be accessed in the download area

at www.bintec-elmeg.com . The remote CAPI client software is installed in the BRICKware

program group.
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Fig. 118: Remote Clients Configuration

(1) To log in the remote CAPI client, the Device IP address or host name of the bintec

R1200must be saved.

(2) Under User enter , for example.

(3) Enter the password.

(4) Apply the configuration with Use these values.

(5) As confirmation, a corresponding message appears in the info area of the remote

CAPI client software.

Detailed in information about the configured CAPI servers and their CAPI controllers is

provided under Remote Multi CAPI Client Configuration .

Following login of the remote CAPI client software bintec router, which functions as CAPI

server, one CAPI controller is displayed per ISDN interface.

Fig. 119: Remote Multi CAPI Client Configuration
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8.2.3 CAPI port configuration for the Remote CAPI interface

With basic installation of the Tobit David, the Tobit Software -> David program group was

installed on your server. There you will find the David Administrator for configuration of

the David. In this section, the dialog for configuration of the ISDN hardware is launched via

the option Ports -> add Port. Follow the administrator's instructions.

(1) Go to David -> System -> Ports.

Fig. 120: XP-2 - David Administrator

With Hardware Detection , Port Setup locates the remote CAPI controller.

Fig. 121: Hardware detection

(1) Enable .

The next Port Setup step allows selection of services assigned to this CAPI port.
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Fig. 122: Selection of services

(1) For the remote CAPI port of the bintec R1200, select the services ,

and .

In the next step, a unique name is assigned to the port.

Fig. 123: Advanced hardware configuration

(1) Under Description enter , for example.

The Operation Mode as well as the option

may be transferred without modification.
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Fig. 124: Advanced hardware configuration

Fig. 125: Advanced hardware configuration

In the final step of Port Setup, an ISDN Multi Subscriber Number (MSN) is assigned to the

port. This call number is used for incoming connections after completed configuration.

Fig. 126: Advanced hardware configuration
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(1) Under MSN 0 enter , for example.

(2) This concludes the configuration. Click on Complete.

To be able to use both B-channels of the ISDN point-to-multipoint connection, an additional

port must be created. In this example, the existing port is duplicated.

(1) Go to David -> Ports-> Duplicate....

Fig. 127: XP-2 - David Administrator

In the properties of the configured port you can, among other things, set which user re-

ceives an incoming fax message.

(1) Go to PORT 011 - bintec R1200 -> Advanced

Fig. 128: PORT 001 - bintec R1200
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(1) Under Route to select , for example.

You can now send a test fax in the David InfoCenter.

Enter the recipient's fax number in the address field, and create a message.

Fig. 129: Test fax

Further configuration of the David by Tobit will not be addressed here. For this, we refer

you to our Technology Partner, Tobit Software.

8.3 Overview of configuration steps

MSN Configuration

Field Menu Value

ISDN Port Physical Interfaces -> ISDN Ports ->

MSN Configuration -> New

Service Physical Interfaces -> ISDN Ports ->

MSN Configuration -> New

MSN Physical Interfaces -> ISDN Ports ->

MSN Configuration -> New

e.g.

MSN Recognition Physical Interfaces -> ISDN Ports ->

MSN Configuration -> New

Service attribute Physical Interfaces -> ISDN Ports ->

MSN Configuration -> New

Remote CAPI server configuration
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Field Menu Value

Enable server Local Services ->CAPI Server ->Op-

tions

CAPI Server TCP

Port

Local Services ->CAPI Server ->Op-

tions

e.g.

User Name Local Services ->CAPI Server ->User->

New.

e.g.

Password Local Services ->CAPI Server ->User->

New.

Access Local Services ->CAPI Server ->User->

New.

Configuration of remote CAPI client software

Field Menu Value

Device IP address or

host name

Remote Clients Configuration e.g.

User Remote Clients Configuration

Password Remote Clients Configuration

Hardware detection

Field Menu Value

Detect hardware

automatically

Port Setup enable

Fax group 3 Port Setup enable

Voice Mail

(answering machine)

Port Setup enable

TAPI (ECT) Port Setup enable

Description Port Setup e.g.

Operation Mode Port Setup

ISDN point-

to-multipoint connec-

tion

Port Setup enable

MSN0 Port Setup e.g.

Duplicate port

Field Menu Value

Duplicate... David -> System -> Ports enable
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Field Menu Value

Route to bintec R1200 -> Advanced e.g.
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Chapter 9 Media Gateway - Connecting a virtu-

alised Tobit David.fx server to a Primary Rate

Interface with a bintec RT4402

9.1 Introduction

This chapter describes how to connect, running in a virtual environment, Tobit David.fx

2011 servers to a 30-channel Primary Rate interface (point-to-point connection) with a

3-digit direct dialling range. The David.fx server uses the remote CAPI interface in the

bintec RT4402 gateway to communicate.

The GUI (Graphical User Interface) is used here to configure the bintec RT4402.

Fig. 130: Example scenario

Requirements

• A bintec RT4402 gateway with system software 7.10.1

• A fax licence for the bintec RT4402 gateway

• Basic installation of the Tobit David.fx server is assumed, along with an existing VMware

environment.

• A Primary Rate interface

9.2 Configuration
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9.2.1 Configuring the bintec RT4402

Activate the fax licence

With the bintec RT4402, the T.30 protocol for G3 fax needs to be activated by a fax li-

cence. Once this licence has been authorised in the Service area on our website

www.bintec-elmeg.com , the licence can be entered in the web interface on the bintec

RT4402.

Note

The fax licence must be activated by rebooting the bintec RT4402 gateway.

(1) Go to System Administration -> Global Settings -> System Licences.

Fig. 131: System Management -> Global Settings -> System Licences

Configure the ISDN Primary Rate interface

The bintec RT4402 gateway can be connected to a provider's Primary Rate interface or to

an internal S2M bus in a telephone system which is wired with the DSS1 protocol.

(1) Go to Physical Interfaces -> ISDN Ports -> ISDN Configuration -> <pri2-4 (TE)
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Fig. 132: Physical Interfaces -> ISDN Ports -> ISDN Configuration -> <pri2-4 (TE)

Proceed as follows to edit the ISDN port configuration:

(1) For Port Usage, select .

(2) Leave the ISDN Line Framing set to .

(3) Under Channel Selection, select . The device tells the PABX that all

channels are available. The exchange of the PABX selects the channel to be used.

(4) Confirm with OK.

Ex works, the router accepts all incoming ISDN connections, thus permitting remote config-

uration via ISDN login. This needs to be prevented, for security reasons. To do this, go to

the following menu:

(1) Go to Physical Interfaces -> ISDN Ports -> MSN Configuration -> New.

Fig. 133: Physical Interfaces -> ISDN Ports -> MSN Configuration -> New

Proceed as follows:

(1) Select the ISDN port for which the MSN is to be configured, e. g. .

(2) For Service, select . This enables logins with ISDN login.

(3) For MSN, enter the number which is used to check the called party number, e. g.

.

(4) For MSN Recognition, select the mode your device is to use to do the numbers com-
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parison for MSN with the called party number of the incoming call, here

.

(5) For Service attribute, select the type of the incoming call (service recognition), here

e. g. .

(6) Confirm with OK.

Remote CAPI server configuration

The CAPI service allows connection of incoming and outgoing data and voice calls to com-

munications applications on hosts in the LAN that access the Remote CAPI interface of

your device. This enables hosts connected to your device to receive and send faxes.

The remote CAPI server of the bintec RT4402 is already enabled ex-works.

(1) Go to Local Services -> CAPI Server->Options.

Fig. 134: Local Services ->CAPI Server ->Options

For security reasons, access to the remote CAPI interface should still be protected with a

user name and password.

You use the symbol to edit the existing user "default".

(1) Go to Local Services -> CAPI Server -> User -> <default> .
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Fig. 135: Local Services -> CAPI Server -> User -> <default>

Proceed as follows to protect the CAPI interface:

(1) For Username, enter the name for which access to the CAPI service is to be allowed

or denied, e. g. .

(2) Enter the Password that the user will use to identify themselves to gain access to the

CAPI service, e. g. .

(3) Enable the Access option. Now the user is permitted to access the CAPI service.

(4) Confirm with OK.

9.2.2 Configuration of remote CAPI client software

To install the remote CAPI interface, use the latest installation pack Remote CAPI for MS-

WINDOWS. You can get this, in both 32-bit and 64-bit versions, from the download area on

our website www.bintec-elmeg.com .

The LAN CAPI configuration software is installed in the program group Bintec Brickware .
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Fig. 136: Remote Clients Configuration

(1) To log in the remote CAPI client, the IP address or host name of the bintec RT4402

gateway must be saved.

(2) Under User Name enter e. g. .

(3) Enter the Password , e. g. .

(4) Apply the configuration with Apply.

(5) As confirmation, a corresponding message appears in the info area of the remote

CAPI client software.

Detailed information about the configured CAPI servers and their CAPI controllers is

provided under the Multiple Devices (CAPI 2032.dll) option.

In our example, there must be a CAPI controller available with 30 channels.
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Fig. 137: Remote Multi CAPI Client Configuration

9.2.3 CAPI port configuration for the Remote CAPI interface

When the basic installation of the Tobit David was done, the Tobit Software -> David.fx

program group was created on your server. There you will find the David Administrator

for configuring the Tobit David.fx ports to communicate with the bintec Remote CAPI. In

this menu, the dialog for configuring the ISDN hardware is opened via the Ports -> Add

Ports option.

(1) Go to David -> System -> Ports.
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Fig. 138: David.fx Administrator

With Hardware Detection , Port Setup locates the remote CAPI controller.

Fig. 139: Hardware detection

(1) Enable .

The next Port Setup step allows selection of services assigned to this CAPI port.
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Fig. 140: Selection of services

(1) For the remote CAPI port of the bintec RT4402, select the services ,

and .

The Operating Mode is set to and the Access Configur-

ation is set to due

to the Primary Rate interface.

Fig. 141: Advanced hardware configuration
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Fig. 142: Advanced hardware configuration

In the final step in the port setup, the call number length of your own number including the

DDI block (e. g. 8 digits) is specified. This results in incoming connections being accepted

immediately, as soon as the target number has reached a length of 8 digits.

Fig. 143: Advanced hardware configuration

Once the first CAPI port has been created using the wizard, its properties need to be adjus-

ted. Right-click on the CAPI port you have created to be able to edit the port's properties.

The option must be enabled in the DDI menu.
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Fig. 144: Advanced hardware configuration

When the wizard has finished creating a new Tobit David.fx CAPI port, the installation can

be used for incoming and outgoing connections via an ISDN channel. To be able to use all

the channels, one more CAPI port needs to be created for each available ISDN channel. In

this example, the existing port is duplicated.

(1) Go to David -> Ports-> Duplicate....

Fig. 145: David Administrator

You can now send a test fax in the David client.

Enter the recipient's fax number in the address field, and create a message.
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Fig. 146: Test fax

Further configuration of the David by Tobit will not be addressed here. For this, we refer

you to our Technology Partner, Tobit Software.

The console or the Telnet or SSH access should be used to debug the bintec RT4402 fax

connections, because the messages cannot be seen in real time here. After logging in, use

the command to enable the outputting of log messages.
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9.3 Overview of Configuration Steps

ISDN Configuration

Field Menu Value

Port Usage Physical Interfaces -> ISDN Ports ->

ISDN Configuration -> <pri2-4 (TE)

ISDN Line Framing Physical Interfaces -> ISDN Ports ->

ISDN Configuration -> <pri2-4 (TE)

Channel Selection Physical Interfaces -> ISDN Ports ->

ISDN Configuration -> <pri2-4 (TE)

MSN Configuration

Field Menu Value

ISDN Port Physical Interfaces -> ISDN Ports ->

MSN Configuration -> New

Service Physical Interfaces -> ISDN Ports ->

MSN Configuration -> New

MSN Physical Interfaces -> ISDN Ports ->

MSN Configuration -> New

e. g.

MSN Recognition Physical Interfaces -> ISDN Ports ->

MSN Configuration -> New

Service attribute Physical Interfaces -> ISDN Ports ->

MSN Configuration -> New

Remote CAPI server configuration

Field Menu Value

Enable server Local Services ->CAPI Server ->Op-

tions

User Name Local Services ->CAPI Server ->User->

New.

e. g. .

Password Local Services ->CAPI Server ->User->

New.

e. g.

Access Local Services ->CAPI Server ->User->

New.

Configuration of remote CAPI client software
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Field Menu Value

IP address or host

name of the device

Remote Clients Configuration e. g.

User Name Remote Clients Configuration e. g. .

Password Remote Clients Configuration e. g.

Hardware detection

Field Menu Value

Detect hardware

automatically

Port Setup enable

Fax group 3 Port Setup enable

Voice Mail

(answering machine)

Port Setup enable

TAPI (ECT) Port Setup enable

Operation Mode Port Setup

ISDN access

(point-to-multipoint

connection)

Port Setup enable

DDI Length Port Setup e. g.

Duplicate port

Field Menu Value

Duplicate... David -> System -> Ports enable
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Chapter 10 Media Gateway - bintec R1200

VoIP/R4100 VoIP as Unified Messaging Gate-

way for Microsoft Exchange Server 2007

10.1 Introduction

The present chapter describes connection of the unified messaging roll for Microsoft Ex-

change Server 2007 to the public telephone network or a PBX with a bintec R1200 VoIP or

bintec R4100 VoIP media gateway.

The unified messaging roll for Microsoft exchange server 2007 offers the following func-

tions:

• Access to e-mails and voice messages, appointments and contacts by voice control/tone

dialling

• Server for fax reception

• Answering machine function with message delivery by e-mail

• Auto Attendant / call relay

Fig. 147: Example scenario

Requirements

• A bintec R1200 VoIP or bintec R4100 VoIP

• Microsoft Exchange Server 2007 with Unified Messaging Roll

• Access to the public telephone network or a PBX
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10.2 Configuration

10.2.1 Configuration steps on Microsoft Exchange server

Configuration of the Microsoft Exchange server is performed with the exchange adminis-

tration console :

Fig. 148: Exchange administration console

Creation of a dial plan

In the Unified Messaging menu, you can launch the wizard to create a new UM dial plan.

(1) Go to Organization Configuration -> Unified Messaging -> New UM Dial Plan...
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Fig. 149: New UM dial plan

To create a new UM dial plan, proceed as follows:

(1) Enter the dial plan name, e. g. .

(2) In Number of digits in extension numbers set the number of direct dial-in numbers,

e.g., .

(3) In URI type select a designation for the resources, e.g. .

(4) In VoIP security select .

(5) With the option New, you create the new dial plan.

Fig. 150: New UM dial plan

Click on Finish to close the wizard.

After the wizard is closed, dial plan properties must be edited.
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Fig. 151: Subscriber Access

Under demo_dialplan Properties -> Subscriber Access the call number under which the

system may later be reached is saved, e.g., .

Fig. 152: Dial Codes

Under demo_dialplan Properties -> Dial Codes national and other prefixes are saved.

To save the prefixes, proceed as follows:

First, enter the numbers for outgoing calls.
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(1) In the Outside line access codefield, you can save a number for an outside line.

(2) In International access code enter the international access number .

(3) In National number prefix enter the national prefix, here .

(4) In Country/Region code enter the country code, e.g., for Germany.

Now enter the numbers for incoming calls.

(1) In In-country/region number format enter .

(2) In International number format enter the prefix, e.g., for Germany.

Fig. 153: Settings

In the Settings submenu, notably the language codecs and the language with which the

system shall respond are saved.

To save additional settings, proceed as follows:

(1) In Dial by name primary method select, for example, .

(2) In Dial by name secondary method select .

(3) In Audio codec enter language codec .

(4) For Operator extension enter the switchboard number, for example, .

(5) In Default language select the language in which the system shall subsequently an-

swer, e.g., .

In the submenu Dialing Rule Groups a UM dial plan is defined. This determines which

type of calls the UM-enabled user can make. In our example, national and international

connections are permitted. Dialing Rule Groups also allow transformation of destination
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numbers (e.g. setting of a specific prefix).

Fig. 154: Dialing Rule Groups

In the submenu Dialing Restrictions, it is determined which kinds of calls are permitted or,

as the case arises, prohibited.

Fig. 155: Dialing Restrictions

The newly-created dial plan is subsequently allocated to a UM server. The dial plan can be

added in Server Properties UM Settings. Here are administered the installed language

packs and the restriction on the maximum possible number of voice and fax connections.
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(1) Go to Server Configuration -> Unified Messaging -> UM Settings.

Fig. 156: UM Settings

Creation of a UM IP Gateway

A new UM IP gateway is created with the assistant in the Unified Messaging submenu.

(1) Go to Organization Configuration -> Unified Messaging -> New UM IP Gateway.

Fig. 157: New UM IP gateway

To create a new UM IP gateway, proceed as follows:

(1) In Name enter, for example, .

(2) Enter the IP address at which the UM gateway is accessible, e.g. .

(3) In Fully qualified domain name (FQDN) you can enter the name under which the

UM gateway is accessible.
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(4) Next, the previously-created Dial Plan is assigned.

Creation of a UM hunt group

The Hunt Groups are required for drive of the exchange server by the UM gateway . The

assistant for creation of a new UM hunt group is launched on the exchange administra-

tion console.

(1) Go to Organization Configuration -> Unified Messaging -> New UM Hunt Group.

Fig. 158: New UM Hunt Group

To create a new UM hunt group, proceed as follows:

(1) In Name enter the name of the hunt group, e.g., .

(2) In Dial plan select .

(3) The number of the Pilot identifier, here , for example, is later saved at the UM

gateway as a VoIP extension in order to create a connection to the Exchange Server

2007.

You can view the completed configuration in the menu Organization Configuration ->

Unified Messaging -> UM IP Gateways.
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Fig. 159: UM IP Gateways

Configuration of a UM Mailbox Policy

Already when creating a Dial Plan a standard UM Mailbox Policy is created.

Fig. 160: Default Policy Properties

In properties of UM Mailbox Policy, in the Message Text submenu, various text templates

can be saved; these can be sent to the UM user per e-mail (e.g., when activating the uni-

fied messaging mailbox or when resetting the unified messaging PIN).
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Fig. 161: Message Text

In the submenu PIN Policies, different properties of the UM PIN (e.g., PIN length) reques-

ted when accessing the UM system can be modified.

Fig. 162: PIN Policies

In the submenu Dialing Restrictions, it is determined which kinds of calls are permitted or,

as the case arises, prohibited.
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Fig. 163: Dialing Restrictions

Auto Attendants (optional)

Configuration of an Auto Attendant , a type of electronic telephone switchboard, is option-

al. For the Auto Attendant an additional Hunt Group should be created, under whose Pi-

lot Identifier (extension number) the electronic switchboard position can be reached.

Activation of unified messaging for an exchange mailbox

In the Mailbox submenu, the unified messaging functions for an exchange mailbox/ex-

change user can be activated via an assistant. For this, the previously configured Unified

Messaging Mailbox Policy must be saved, along with a PIN (for authentication).

(1) Go to Organization Configuration -> Recipient Configuration -> Mailbox.
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Fig. 164: Mailbox

In the assistant's second step, a Mailbox Extension (mailbox number) for the user must

be saved. The Mailbox Extension should match the user's direct dial-in number.

Fig. 165: Mailbox Extension

10.2.2 Configuration of the bintec media gateway

In our example, the bintec media gateway is connected to a PBX internal ISDN port with

extension number 500 via the external ISDN S0 interface (e.g. ISDN-0). The ISDN auto-

recognition provides detection of a point-to-point or point-to-multipoint connector.

(1) Go to Physical Interfaces ->ISDN Ports-><bri2-0 (TE)> .
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Fig. 166: Physical Interfaces -> ISDN Ports -> <bri2-0 (TE)> .

Relevant fields in the ISDN Configuration menu

Field Meaning

Port Name Shows the name of the ISDN port.

Autoconfiguration on

Bootup

Autoconfiguration at bootup is enabled.

Result of Autoconfigura-

tion

Shows the status of the ISDN Auto Config.

Connection of the exchange server as VoIP/SIP subscriber

Microsoft Exchange Server 2007 is configured at the media gateway as SIP extension.

(1) Go to VoIP -> Media Gateway -> Extensions -> New.
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Fig. 167: VoIP -> Media Gateway -> Subscriber -> New

Relevant fields in the Extensions menu

Field Meaning

Description Enter the name of the terminal, e.g. .

Extension / User Name Here the number under which the system can be accessed is

saved, in this case .

Registration Disable the registration mechanism.

SIP Endpoint IP Address Here, the IP address of the Microsoft exchange server must be

saved, e.g. .

Protocol Select protocol to be used for data transmission.

Port For connection to the Microsoft exchange server identify port

.

The Advanced Settings menu consists of the following fields:

Relevant fields in the menu Advanced Settings
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Field Meaning

Sort Order Enable options and .

Call routing configuration at the media gateway

To allow outgoing connections toward the PBX/PSTN, a route in menu Call Routing must

be created. With this routing entry, all calls are routed to the ISDN PBX via the ISDN inter-

face.

(1) Go to VoIP -> Media Gateway -> Call Routing -> New.

Fig. 168: VoIP -> Media Gateway -> Call Routing -> New

Relevant fields in the Call Routing menu

Field Meaning

Description Enter the name of the call routing entry, e.g. .

Type Specify how calls are to be routed. With for calls that

are to be routed as outgoing external calls.

Calling Line You can restrict the routing entry to the line on which the call

comes in. With there is no restriction of routing entries.

Called Address
You can enter an address numerically (e.g. a subscriber num-

ber) or alphanumerically (e.g. for a trunk) that is to be compared

with a dialled address. You can use wildcards here.
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Field Meaning

* means that at the end of a character string any number of

characters may follow,

In the Routing Rules area, you can define the line/provider over which outgoing connec-

tions are routed

10.2.3 Function test

At the first function test, it is possible to call from the telephone extension of the unified

messaging user (e.g., demo user with extension number ) to the ex-

tension of the exchange server (e.g., extension ). Microsoft Exchange server 2007

should respond with a PIN request and permit access to e-mails, contacts, etc.

At the second function test, a unified messaging user (e.g., demo user

with extension number ) should configure a call diversion to the Microsoft Exchange ex-

tension (call number ). With an incoming call to the user call number, the call/fax is put

through to the user mailbox on the Microsoft Exchange server.
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10.3 Overview of configuration steps

Creation of a dial plan

Field Menu Value

Name Organization Configuration -> Unified

Messaging -> New UM Dial Plan..

e.g.

Number of digits in

extension numbers

Organization Configuration -> Unified

Messaging -> New UM Dial Plan..

e.g.

URI type Organization Configuration -> Unified

Messaging -> New UM Dial Plan..

VoIP security Organization Configuration -> Unified

Messaging -> New UM Dial Plan..

Subscriber Access Organization Configuration -> Unified

Messaging -> New UM Dial Plan..->

Subscriber Access

e.g.

Outside line access

code

Organization Configuration -> Unified

Messaging -> New UM Dial Plan..->

Dial Codes

International access

code

Organization Configuration -> Unified

Messaging -> New UM Dial Plan..->

Dial Codes

National number

prefix

Organization Configuration -> Unified

Messaging -> New UM Dial Plan..->

Dial Codes

Country/Region

code

Organization Configuration -> Unified

Messaging -> New UM Dial Plan..->

Dial Codes

In-country/region

number format

Organization Configuration -> Unified

Messaging -> New UM Dial Plan..->

Dial Codes

International number

format

Organization Configuration -> Unified

Messaging -> New UM Dial Plan..->

Dial Codes

Dial by name

primary method

Organization Configuration -> Unified

Messaging -> New UM Dial Plan..->

Settings

e.g.

Dial by name sec-

ondary method

Organization Configuration -> Unified

Messaging -> New UM Dial Plan..->
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Field Menu Value

Settings

Audio codec Organization Configuration -> Unified

Messaging -> New UM Dial Plan..->

Settings

Operator extension Organization Configuration -> Unified

Messaging -> New UM Dial Plan..->

Settings

e.g.

Logon failures be-

fore disconnect

Organization Configuration -> Unified

Messaging -> New UM Dial Plan..->

Settings

e.g.

Default language Organization Configuration -> Unified

Messaging -> New UM Dial Plan..->

Settings

e.g.

In-Country/Region

Rule Groups

Organization Configuration -> Unified

Messaging -> New UM Dial Plan..-> Di-

aling Rule Groups

, ,

International Rule

Groups

Organization Configuration -> Unified

Messaging -> New UM Dial Plan..-> Di-

aling Rule Groups

, ,

Allow calls to uses

within the same dial

plan

Organization Configuration -> Unified

Messaging -> New UM Dial Plan..-> Di-

aling Restrictions

Allow calls to exten-

sions

Organization Configuration -> Unified

Messaging -> New UM Dial Plan..-> Di-

aling Restrictions

Aktiviert

Creation of a UM IP Gateway

Field Menu Value

Name Organization Configuration -> Unified

Messaging -> New UM IP Gateway

e.g.

IP Address Organization Configuration -> Unified

Messaging -> New UM IP Gateway

e.g.

Dial plan Organization Configuration -> Unified

Messaging -> New UM IP Gateway

Creation of a UM hunt group

Field Menu Value

Associated UM IP

gateway

Organization Configuration -> Unified

Messaging -> New UM Hunt Group

e.g.
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Field Menu Value

Name Organization Configuration -> Unified

Messaging -> New UM Hunt Group

e.g.

Dial plan Organization Configuration -> Unified

Messaging -> New UM Hunt Group

e.g.

Pilot identifier Organization Configuration -> Unified

Messaging -> New UM Hunt Group

e.g.

Configuration of a UM Mailbox Policy

Field Menu Value

Fax identity Organization Configuration -> Unified

Messaging -> New UM Mailbox Policy -

> Message Text

Text send when a

UM mailbox is en-

abled

Organization Configuration -> Unified

Messaging -> New UM Mailbox Policy -

> Message Text

e.g.

Text send when a

PIN is reset

Organization Configuration -> Unified

Messaging -> New UM Mailbox Policy -

> Message Text

e.g.

Text included with a

voice message

Organization Configuration -> Unified

Messaging -> New UM Mailbox Policy -

> Message Text

z. B.

Text included with a

fax message

Organization Configuration -> Unified

Messaging -> New UM Mailbox Policy -

> Message Text

e.g.

Minimum PIN length Organization Configuration -> Unified

Messaging -> New UM Mailbox Policy -

> PIN Policies

e.g.

Number of previous

PINs to disallow

Organization Configuration -> Unified

Messaging -> New UM Mailbox Policy -

> Message Text

e.g.

Number of incorrect

PIN entries before

PIN is automatically

reset

Organization Configuration -> Unified

Messaging -> New UM Mailbox Policy -

> Message Text

e.g.

Number of incorrect

PIN entries before

UM mailbox is

locked out

Organization Configuration -> Unified

Messaging -> New UM Mailbox Policy -

> Message Text

e.g.

Allow calls to uses Organization Configuration -> Unified Aktiviert
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Field Menu Value

within the same dial

plan

Messaging -> New UM Mailbox Policy -

> Dialing Restrictions

Allow calls to exten-

sions

Organization Configuration -> Unified

Messaging -> New UM Mailbox Policy -

> Dialing Restrictions

Aktiviert

Activation of unified messaging for an exchange mailbox

Field Menu Value

Unified Messaging

Mailbox Policy

Organization Configuration -> Recipi-

ent Configuration -> Mailbox

e.g.

Manually specify

PIN

Organization Configuration -> Recipi-

ent Configuration -> Mailbox

Your PIN

Manually entered

mailbox extension

Organization Configuration -> Recipi-

ent Configuration -> Mailbox

e.g.

ISDN Configuration

Field Menu Value

Autoconfiguration on

Bootup

Physical Interfaces -> ISDN Ports ->

<bri2-0 (TE)> .

SIP extension configuration

Field Menu Value

Description VoIP -> Media Gateway -> Subscriber -

> New

e.g.

Extension / User

Name

VoIP -> Media Gateway -> Subscriber -

> New

SIP Endpoint IP Ad-

dress

VoIP -> Media Gateway -> Subscriber -

> New

e.g.

Protocol VoIP -> Media Gateway -> Subscriber -

> New

Port VoIP -> Media Gateway -> Subscriber -

> New

Sort order VoIP -> Media Gateway -> Extensions -

> New-> Advanced Settings

,

Configuration of call routing

Field Menu Value

Description VoIP -> Media Gateway -> Call Routing e.g.
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Field Menu Value

-> New

Type VoIP -> Media Gateway -> Call Routing

-> New

Calling Line VoIP -> Media Gateway -> Call Routing

-> New

Called Address VoIP -> Media Gateway -> Call Routing

-> New

Priority VoIP -> Media Gateway -> Call Routing

-> New-> Add

e.g.

Outbound Line VoIP -> Media Gateway -> Call Routing

-> New-> Add

e.g.
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Chapter 11 Media Gateway - Connecting the IP

PBX hybird 300 to an SIP provider via bintec

RS232b gateway

11.1 Introduction

Below is a description of how to connect the IP PBX elmeg hybird 300 to a VoIP provider.

Access to the Internet is established with the aid of a bintec RS232b gateway. The VoIP

provider (e.g. sipgate) can be accessed via the Internet.

The GUI (Graphical User Interface) is used for configuration.

Fig. 169:

Requirements

• An elmeg hybird 300

• A bintec RS232b gateway with system software of 7.9.5 upwards

• Internet access

• Configuring the local IP address with the aid of the Dime Manager

• Setting up the Internet access at the bintec RS232b gateway

• Adapting firewall and quality of service to the internal bintec RS232b gateway

• Configuring the VoIP provider settings of the elmeg hybird 300

• Checking the QoS function at the bintec RS232b gateway

bintec elmeg GmbH 11 Media Gateway - Connecting the IP PBX hybird 300 to

an SIP provider via bintec RS232b gateway

Workshops (Excerpt) 191



11.2 Configuration

11.2.1 Configuring the local IP address with the aid of the

Dime Manager

After the the elmeg hybird 300 and the bintec RS232b have been integrated in the local

network, they can be located via the Dime Manager. The Dime Manager now offers the

option of setting the local IP address via the context menu.

(1) Go to Dime Manager -> IP Settings.

Fig. 170: Dime Manager -> IP Settings

In this workshop, the address 192.168.1.254/24 is assigned to the bintec RS232b gateway

and the address 192.168.1.100/24 with standard gateway 192.168.1.254 for the IP PBX el-

meg hybird 300.
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11.2.2 Setting up the Internet access at the bintec RS232b

gateway

To configure the Internet access at the bintec RS232b gateway the GUI has a wizard. Go

to the following menu:

(1) Go to Assistants -> Internet access -> Internet connections -> New.

(2) At Connection type, select .

(3) Click on Continue in order to configure a new Internet connection.

Enter the required data for the Internet connection.

Fig. 171: Assistants -> Internet access -> Internet connections -> Continue.

Proceed as follows, to configure a new Internet connection:

(1) At Description, enter any designation for the Internet connection, e.g.

.

(2) Under Internet Service Provider, select the profile .

(3) For Username, enter the access data given to you by your provider, e.g.

.

(4) Enter the Password given to you by your provider, e.g .

(5) Confirm the details with OK.
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11.2.3 Adapting Firewall and Quality of Service to the internal

bintec RS232b gateway

The bintec RS232b gateway uses, among others, Network Address Translation (NAT) as

Firewall mechanism (Symetric NAT) to block undesirable data from the Internet. To ensure

an uninterrupted VoIP connection, it must be guaranteed that the VoIP PBX in the LAN ( el-

meg hybird 300) uses a different NAT type (Full_cone NAT). In addition, the VoIP data

(call signalling and the pure voice data) are to be prioritised with Quality of Service (QoS).

(1) Go to Assistants -> VoIP PBX in LAN -> VoIP PBX in LAN -> New.

Fig. 172: Assistants -> VoIP PBX in LAN -> VoIP PBX in LAN -> New.

Proceed as follows in order to make the necessary settings:

(1) For WAN interface VoIP prioritisation , for example, select .

(2) For Maximum Upload Speed, for example, enter kbit/s.

(3) With the setting DSCP filter for prioritisation on , a

filter for recognising and subsequently prioritising the VoIP data traffic of the IP PBX

VoIP is configured. The elmeg hybird 300 signals the VoIP data traffic with DSCP

value 46 (decimal format) or 101110 (binary format).

(4) With option IP Address of VoIP PBX , the IP address of the local IP PBX (elmeg hy-

bird 300) is queried. With Add, you add an entry, e.g., . This entry

automatically changes the Network Address Translation Mode.

(5) Confirm the entry with OK.
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11.2.4 Configuring the VoIP provider settings of the elmeg hy-

bird 300

Before the VoIP settings of the SIP provider are stored in the web interface of the elmeg

hybird 300, their network settings must have been completed.

(1) Go to Assistants -> First Steps.

Fig. 173: Assistants -> First Steps

Proceed as follows in order to complete the network settings:

(1) The System Name can be changed in the assistant, here , for example.

(2) For Location, for example, enter .

(3) For Contact, for example, enter .

(4) Also the password can be changed in the assistant, here ,

for example.

(5) In the sector LAN IP Configuration, enter the Standard gateway IP Address , here

.

(6) For DNS Server 1, enter the address of the bintec RS232b, in this case
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.

(7) Confirm the entry with OK.

For every connection set-up of a VoIP call, the IP PBX elmeg hybird 300 calculates which

speech coding (e.g. G.711) is used and whether the connection can be developed with the

available bandwidth. A location profile for the VoIP provider is created for this.

(1) Go to VoIP -> Settings -> Locations -> New.

Fig. 174: VoIP -> Settings -> Locations -> New.

Proceed as follows in order to set up the location profile for the VoIP provider:

(1) For Description, for example, enter .

(2) Click on Add, in order to configure new addresses. Enter the IP Address of the SIP

server, e.g. .

(3) Enable the option Bandwidth Limitation Upstream.

(4) At Maximum Upstream Bandwidth, enter the maximum data rate in kbit/s per

second in the direction of transmission, e.g. .

(5) Enable the option Bandwidth Limitation Downstream.

(6) For Maximum Downstream Bandwidth, enter the maximum data rate in kbit/s per

second in the direction of transmission, e.g. .

(7) Click on Advanced Settings .

(8) In the case of the DSCP Settings for RTP Data option, the DSCP value for marking

language packs is entered, in this case . With this option, the

same value is assigned that has been configured at bintec RS232b gateway in the

Assistants -> VoIP PBX menu in the LAN . This DSCP value can be entered in dif-
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ferent formats, e.g. in decimal (46) or in binary format (101110).

(9) Confirm the entry with OK.

Following this, the login data of the SIP Provider (here shown with the example of VoIP

provider sipgate) can be stored.

(1) Go to VoIP -> Settings -> SIP Provider -> New.

Fig. 175: VoIP -> Settings -> SIP Provider -> New.

Proceed as follows, in order to store the SIP provider's login data:

(1) For Description, for example, enter a description for the SIP provider, e.g. .

(2) Enter your provider's Authentication Address, e.g. .

(3) Enter the User Name given to you by your VoIP provider, e.g .

(4) Specify the IP address or the domain name of the SIP Registrar, e.g. .

(5) Enter the IP address or the domain name of the STUN server, e.g.

. Since the connection to the VoIP provider is established via an

upstream NAT gateway ( bintec RS232b), a STUN server must also be configured in

the provider settings. The IP PBX elmeg hybird 300 determines the WAN IP address

of the bintec RS232b gateway with the aid of the STUN server.

(6) Confirm your entry with OK.
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11.2.5 Checking the QoS function at the bintec RS232b gate-

way

Go to the following menu to check the quality of service settings on the bintec RS232b

gateway:

(1) Go to Monitoring -> QoS -> QoS.

Fig. 176: Monitoring -> QoS -> QoS

A list of all the interfaces for which the QoS has been configured is displayed in this menu.

Here the IP packages that are sent to the Internet are counted. In the case of VoIP calls,

the entry (High Priority QoS Queue) must be incremented. This ensures

that the call data have a higher priority than the remaining data traffic.

11.3 Overview of configuration steps

Configuring the local IP address

Field Menu Value

IP address Dime Manager -> IP Set-

tings

gateway Dime Manager -> IP Set-

tings

Select connection type
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Field Menu Value

Connection type Assistants-> Internet Ac-

cess -> Internet Connec-

tions -> New.

e. g.

Setting up the Internet connection

Field Menu Value

Description Assistants -> Internet Ac-

cess -> Internet Connec-

tions -> Continue.

e.g.

Internet Service Provider Assistants -> Internet Ac-

cess -> Internet Connec-

tions -> Continue.

e.g.

Username Assistants -> Internet Ac-

cess -> Internet Connec-

tions -> Continue.

e.g.

Password Assistants -> Internet Ac-

cess -> Internet Connec-

tions -> Continue.

e.g.

Adaptation to the Internet gateway

Field Menu Value

WAN interface for VoIP prior-

itisation

Assistants -> VoIP PBX in

LAN -> VoIP PBX in LAN ->

New.

e.g.

Maximum Upload Speed Assistants -> VoIP PBX in

LAN -> VoIP PBX in LAN ->

New.

e.g.

DSCP filter for prioritisation Assistants -> VoIP PBX in

LAN -> VoIP PBX in LAN ->

New.

e.g.

and

IP Address of the VoIP PBX

in the LAN

Assistants -> VoIP PBX in

LAN -> VoIP PBX in LAN ->

New.

e.g.

Configuring VoIP Providers

Field Menu Value

System Name Assistants -> First Steps e.g.

Location Assistants -> First Steps e. g.

Contact Assistants -> First Steps e.g.
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Field Menu Value

System Admin Password Assistants -> First Steps e.g.

Default gateway IP Address Assistants -> First Steps e.g.

DNS Server 1 Assistants -> First Steps e.g.

Setting up a location profile for the VoIP provider

Field Menu Value

Description VoIP -> Settings -> Loca-

tions -> New.

e.g.

Addresses VoIP -> Settings -> Loca-

tions -> New.

e.g.

Maximum Upstream Band-

width

VoIP -> Settings -> Loca-

tions -> New.

e.g.

Maximum Downstream

Bandwidth

VoIP -> Settings -> Loca-

tions -> New.

e.g.

DSCP Settings for RTP Data VoIP -> Settings -> Loca-

tions -> New-> Advanced

Settings

e.g.

and

Storing SIP provider's login data

Field Menu Value

Description VoIP -> Settings -> SIP Pro-

vider -> New.

e.g.

Authentication ID VoIP -> Settings -> SIP Pro-

vider -> New.

e.g.

User name VoIP -> Settings -> SIP Pro-

vider -> New.

e.g.

Registrar VoIP -> Settings -> SIP Pro-

vider -> New.

e.g.

STUN Server VoIP -> Settings -> SIP Pro-

vider -> New.

e.g.
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Chapter 12 Media Gateway - Settings on the

elmeg hybird 300 to phone via an SIP provider

(sipgate)

12.1 Introduction

The following describes configuration of an SIP provider using an elmeg hybird 300.

The pictured information is only provided as an example. Please use the data obtained

from your SIP provider. When using an inland SIP provider, certain presets are important,

e.g. in order not to have to enter the entire prefix and number in case of a local call, but

rather only the number itself. When connecting the elmeg hybird 300 to an existing net-

work, configuration of the border router must be taken into account.

The GUI (Graphical User Interface) is used for configuration.

Fig. 177: Example scenario

Prerequisites

• An elmeg hybird 300 with system software 7.9.1 patch 4

• A bintec RS232b with system software 7.9.5 patch 4
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• An Internet access

12.2 Configuration

12.2.1 Configuring the bintec RS232bw

Session Initiation Protocol (SIP) serves as a translation instance between different telecom-

munications networks, e.g between the plain old phone network and the next generation

networks (IP networks). To create SIP connections, go to the following menu:

(1) Go to VoIP -> SIP -> Options.

Fig. 178: VoIP ->SIP-> Options

Proceed as follows to perform the SIP settings:

(1) Activate the SIP Proxy. The SIP connections are forwarded.

(2) Activate Prioritise SIP Calls.

(3) Press OK to confirm your entry.

Note

These settings are important, as problems may otherwise arise in calls via a SIP pro-

vider.

12.2.2 Configuration of the elmeg hybird 300

Over the assistant you can configure the settings required for login to an external SIP pro-

vider.

(1) Go to Assistants -> First Steps -> Basic Settings.
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Fig. 179: Go to Assistants -> First Steps -> Basic Settings.

Proceed as follows to make the SIP settings:

(1) In Assistants, the System name can be modified, here, for example .

(2) For Standard Gateway IP Address enter the IP address of your gateway providing

Internet access, e.g. .

(3) For DNS Server 1 enter the IP address of the name server for the name resolution of

Internet addresses .

(4) Press OK to confirm your entry.

For automatic generation of international and national numbers, you must perform the fol-

lowing settings:

(1) Go to System Administration -> Global Settings -> System.
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Fig. 180: System Management -> Global Settings -> System

Proceed as follows to configure the numbers:

(1) Under International prefix / country code enter the country code, e.g., for Ger-

many. Without the entry, for SIP providers the entire call number with country code

must be dialled.

(2) Under National Prefix / Area code enter the area code for the location where your

system is installed, e.g. . This area code is crucial for a point-to-point connec-

tion, as otherwise, automatic callback to an external number, for example, is not pos-

sible.

(3) Confirm with OK.

12.2.3 Registering bintec TR200 with provider sipgate

The login data for registering the VoIP provider accounts with provider sipgate are entered

in the SIP Providers menu.

(1) Go to VoIP -> Settings -> SIP Providers -> New.
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Fig. 181: VoIP -> Settings -> SIP Providers -> New.

To save SIP provider login data, proceed as follows:

(1) Under Description enter a description for the SIP provider, e.g. .

(2) Enter your provider's Authentication ID e.g. .

(3) Enter the User Name you received from your VoIP provider, e.g. .

(4) Indicate the IP address or domain name of the SIP Registrar e.g. .

(5) Press OK to confirm your entry.

In the menu VoIP ->Settings -> SIP Providers the current VoIP configuration is displayed.

It takes less than a minute to register a new SIP provider account with the provider. As

soon as the enrolment process has been completed successfully, the status is set automat-

ically to (active).

Fig. 182: VoIP -> Settings -> SIP Providers .
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You change the status of VoIP configuration by pressing the button or button in the

Action column.

Next, login data of the SIP provider can be saved. For the prefix to be automatically added

before the dialled number, the Generate National Number option must be enabled. For

this, go to the following menu:

(1) Go to VoIP -> Settings -> SIP Providers -> Advanced Settings .

Fig. 183: VoIP -> Settings -> SIP Providers -> Advanced Settings .

To automatically generate the prefix, proceed as follows:

(1) Enable the option Generate National Number. The prefix you've entered under Na-

tional prefix / area code is automatically generated (e. g. for 5171 the prefix 05171 is

automatically added before the dialled number).

(2) Confirm with OK.
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12.3 Overview of configuration steps

Configuring the bintec RS232bw

Field Menu Value

SIP Proxy VoIP ->SIP-> Options Activated

Prioritize SIP Calls VoIP ->SIP-> Options Activated

Configuration of the elmeg hybird 300

Field Menu Value

Standard gateway IP ad-

dress

Go to Assistants -> First

Steps -> Basic Settings.

e.g.

DNS Server 1 Go to Assistants -> First

Steps -> Basic Settings.

e.g.

Generate number

Field Menu Value

International prefix/Country

code

System Management ->

Global Settings -> System

e.g.

National prefix/Area code System Management ->

Global Settings -> System

e.g.

Login with the provider

Field Menu Value

Description VoIP -> Settings -> SIP Pro-

viders -> New.

e.g.

Authentication ID VoIP -> Settings -> SIP Pro-

viders -> New.

e.g.

User Name VoIP -> Settings -> SIP Pro-

viders -> New.

e.g.

Registrar VoIP -> Settings -> SIP Pro-

viders -> New.

e.g.

Automatically generate prefix

Field Menu Value

Create inland call number VoIP -> Settings -> SIP Pro-

viders ->New -> Advanced

Settings

Activated
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